Xash3D is a custom Gold Source build from a scratch. Xash3D overcomes obsolete Gold Source engine's limits and provides for you a new quality of gaming experience and modmaking capabilities, for example: higher limits for bsp-models, studiomodels scaling, realistic values of lighting on server side, entity patch technology support, support of additional map types, support of precaching "on the fly", support for using real HD-textures (up to 4096 x 4096 px) for maps, models, sprites and decals in any played mod and many other features...

Add file Report Xash3D Engine v0.99, build 4097 (outdated)
Location
Engines : Xash3D Engine : Files
Filename
Xash3D_build4097_with_extras.zip
Category
Full Version
Uploader
Qwertyus
Added
Size
3.46mb (3,624,333 bytes)
Downloads
4,458 (2 today)
MD5 Hash
eaf07734a997e70a404fc59d3d4b0197
Embed Button
Embed Widget
Description

In usual anniversary of Xash3D Unkle Mike has released new beta-version of the engine. This release is very close to version 1.0, many things are changed or added, but hereupon they should be carefully tested for proper work.

Preview
Xash3D Engine v0.99, build 4097 (outdated)
Comments  (0 - 50 of 54)
CrusoeDaWolf
CrusoeDaWolf

FPS in this build seems to be capped at 200. Is this a bug or intentional?

Reply Good karma Bad karma+1 vote
nekonomicon
nekonomicon

Unkle Mike wrote about cap in 220 fps when tested new XashXT build. May be bug.

Reply Good karma Bad karma+1 vote
CrusoeDaWolf
CrusoeDaWolf

Alright, thanks. Another issue I noticed is related to AOM:DC. Even if all endings are beaten (i.e all gmgeneral*.aomdc files are present), the AUG doesn't spawn in the bathroom.

Reply Good karma Bad karma+1 vote
CrusoeDaWolf
CrusoeDaWolf

EDIT: Nevermind post above. I fixed that problem.

Reply Good karma Bad karma+1 vote
nekonomicon
nekonomicon

Xash3d really has cap in 200fps. Not a bug.

Reply Good karma Bad karma+1 vote
CrusoeDaWolf
CrusoeDaWolf

Was the cap necessary? Any reason behind it?

Reply Good karma Bad karma+1 vote
supersonicbros369
supersonicbros369

Some graphics cards can overload when there isn't a cap, Sims 3 taught me that.

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus

Check your fps_max parameter. Also check if you have vertical sync enabled in Video modes. Current build has no fps caps except things I've mentioned. Also check video device in the header of your console log - engine shows which card now is used for rendering (if you have more than 1). If you have low fps it's probably a problem of your performance in specific part of current map.

Also, as I wrote many times, Xash3D & GoldSrc have fps-depended game mechanics, so fps uncapping is not good thing for the gameplay and can be source of bugs with animations & physics. The best choice is to limit your fps by enabling vertical sync.

Reply Good karma+1 vote
Guest
Guest

This work for ios 11.3.1 64bit?

Reply Good karma Bad karma0 votes
nekonomicon
nekonomicon

Windows only %)
For iOS 11 try test version of Xash3D FWGS from here: Github.com

Reply Good karma Bad karma+1 vote
Mr.Venari
Mr.Venari

How do i fix this error: DELTA_load: couldnt load file delta.lst

Reply Good karma Bad karma0 votes
nekonomicon
nekonomicon

valve folder from normal Half-Life version contains this file.

Reply Good karma Bad karma+1 vote
FriesNburger
FriesNburger

I can't save the main game or a mod anymore.

Reply Good karma Bad karma+1 vote
FriesNburger
FriesNburger

...and there's a few seconds of lag when starting the game. Same thing when you minimize the game then maximize it.

Reply Good karma Bad karma+1 vote
FriesNburger
FriesNburger

and an error: overflow 4096 tracers... This is an error i have never seen before. Its a very, very, very long list repeating this error.

Maybe it's related to that lag? idk.

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus

Save system have been rewritten. Now old Xash3D game saves are unsupported and can not be loaded, but you can load GoldSrc saves instead. New system was intended to work properly. But it looks like something is wrong with saving a game from main menu. Quicksaving works fine though. Or you can save/load via console commands, like:
save my_game
load my_game

What about lag and tracers. If you use -dev 3 parameter to enable console, try -dev instead. In new build -dev = -dev 3 in old build, and -dev 3 = old -dev 5 (most detailed logging). Users don't need detailed logging in most cases, and it can be a source of performance losses.

Tracers not a problem at all, just can be annoying sometimes if detailed logging is enabled.

Reply Good karma+1 vote
FriesNburger
FriesNburger

im not using -dev at all. Im just using -console.

what about the lag though? whats up with that??
i suppose it has to do with being a beta build.

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus

I'm not sure what kind of lag you mentioned. I don't see significant differencies with how previous builds worked. And I don't have any problems with minimizing. Some lags on first start of the engine can be normal or can be conditioned by HDD cashing or by activity of your anti-virus program. It's if we are talking about time which engine needs to start/load the game at first time. Or do you want to say, that you have lags after map is loaded already? I didn't understand from your words what exactly happens. Try previous builds (3598 for example) to see what happens if you use them. As I said, I see no difference or something else what I could mention as a "lag problem".

Reply Good karma+1 vote
FriesNburger
FriesNburger

the Sierra start up has a lag before it plays and if I minimize the game then maximize then the fps will lag for a few seconds.

its isnt game breaking so I'll just deal with it.

Reply Good karma Bad karma+1 vote
FriesNburger
FriesNburger

okay it seems cfg files don't work correctly now... sigh. it says "execing autoexec.cfg" but doesnt execute all of the commands if have in there. *EDIT* NEVERMIND LOL THIS MESSAGE

Reply Good karma Bad karma+1 vote
FriesNburger
FriesNburger

was the cmd endgame done away with?

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus

There is no such command as endgame. Nor in Xash, nor in GoldSrc.

Autoexec.cfg is not for any parameter. Try userconfig.cfg instead. Also make sure that your commands are supported by Xash3D (some GoldSrc commands are not supported). Also some commands require sv_cheats or developer mode enabled.

Reply Good karma+1 vote
FriesNburger
FriesNburger

i must be not remembering the command name correctly, but I am certain there was a command that ended the current game and went back to the menu. Compare with "quit" which shut down the game completely.

Reply Good karma Bad karma+1 vote
nekonomicon
nekonomicon

AFAIR, disconnect.

Reply Good karma Bad karma+2 votes
FriesNburger
FriesNburger

The lag I mentioned earlier in this discussion still happens when start an older release of xash3d. You mentioned something about HDD cashing; how would I fix regarding this? It's not antivirus because I have it on the "Don't bother" list.

Thank you for taking the time to speak to me

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus

I see no problem in what you call "lag". The things looks normal for me. Game just needs time to load properly. Or maybe it's your system related (if it's really looks like laaaaag for you, lol, but I doubt this).

Reply Good karma+1 vote
FriesNburger
FriesNburger

that's what I'm saying, it's lag for me cause it's something with my system and not the game.

I tried an earlier build where I had no problems and it does the same thing. It's just me that's experiencing this and I thought maybe you could give me an idea.

Reply Good karma Bad karma+2 votes
Qwertyus Author
Qwertyus

Add -dev to commandline / shortcut and intro will be skipped. I doubt you like to watch it everytime anyway. This parameter also enables console and sv_cheats. And please let's finish this almost useless thread.

Reply Good karma+1 vote
FriesNburger
FriesNburger

nah, it still does it; when it starts and after minimizing. You said something about HDD caching, but.... if your too annoyed with this then I'll leave you alone.

Reply Good karma Bad karma+2 votes
Qwertyus Author
Qwertyus

As I said delays are NORMAL, so it's useless to complain about them.

Reply Good karma+2 votes
FriesNburger
FriesNburger

I have never had a problem with delays up until now so it's NOT normal to me. It's okay though I can live with it just thought you might have some ideas.

Reply Good karma Bad karma+2 votes
sjain
sjain

What a ridiculously and unnecessarily patronising way to respond to someone kindly asking for help. Okay he didn't upload logs, and it isn't your job to provide support but be a little less harsh. I see you responding in this tone to almost everyone. We all really really love Xash3D but just calm down man :)

Reply Good karma Bad karma+2 votes
Qwertyus Author
Qwertyus

Oh, excuse me sir, you so right sir, you showed me the righteous way sir, thank you sir.

Reply Good karma+1 vote
FriesNburger
FriesNburger

Thank You. Im starting to wonder if this is the real author... Maybe someone who manages the real author's account cause of fluent english skills I guess?

Reply Good karma Bad karma+2 votes
Qwertyus Author
Qwertyus

You've wrote many words, but you didn't describe your problem well enough. "I have lag". I have no idea of what exactly you called lag. I have delays when game is starting, and it's normal. From your words you just think you have a problem, that's all I see. You seek for help, but how can I help you if I see no problem? That's why this thread looks useless for me. I'm busy man and I'm hate to spend my time for nothing. Moreover, speaking English to you is not so easy for me as you think, especially because I'm trying to be understandable for my interlocutor, what I can't say about you. Try to be understandable, if you want help. Give more detailed information, make a video or just don't waste the time of other people and try to solve the problem on your own. Xash3D's provided as is, without any warranty and it will be better for you if you learn some existing information before asking for help. You don't even know, who the author of the engine, whatever.

Reply Good karma+2 votes
FriesNburger
FriesNburger

Out of curiosity, when do you plan on the next update?

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus

When it will be ready enough to put it there.

Reply Good karma+1 vote
Guest
Guest

Hello, uhm i have a problem i don't know if this is particularly a problem or a bug or I maybe be doing something wrong on the installation, i did everything right on the install process but here it is, whenever i finish the hazard course training (HL, and Blue Shift) I don't go back to the main menu or the game never recognizes the command to 'endgame' the level after completion which a bit annoying and weird, so before i install it again and give it another try, is there a way to fix it or is it some type of bug you guys haven't noticed or fixed, pls. respond and thank you and impressive engine to play half life btw but it really kills me whenever this error happens.

Reply Good karma Bad karma0 votes
Qwertyus Author
Qwertyus

You mean, you see console messages & the last is Host_EndGame? After game ends the engine returns you directly in the main menu only if you don't have developer's mode enabled. If you have developer's mode enabled, you'll be returned in console screen instead of game menu. It's not a bug, Xash3D always behaved like this. Just press Esc & you'll quit from console to the main menu. Or don't enable devmode (use -console instead of -dev).

Reply Good karma+1 vote
Guest
Guest

I cannot save from the main menu. Something to do with the WON menu in the older version extras?

Reply Good karma Bad karma0 votes
Qwertyus Author
Qwertyus

It's a bug of current version of the engine. Try previous version if it bothers you much. You still can save your game with quicksaving/autosaving or using "save" command in console, like:
save my_game_for_example

Reply Good karma+1 vote
Diego0920
Diego0920

Thanks

Reply Good karma Bad karma+1 vote
Guest
Guest

i can't play multiplayer in normal half-life, this option appears disabled

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus

Delete this line from gameinfo.txt in "valve" folder:
gamemode "singleplayer_only"

Reply Good karma+1 vote
lopesdasilvat5
lopesdasilvat5

Hey Help me please when I open the program it will have a white screen and only to hear the sound of the game

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus Reply Good karma+1 vote
lopesdasilvat5
lopesdasilvat5

continued with the white screen did not help me at all

Reply Good karma Bad karma+1 vote
Qwertyus Author
Qwertyus

You may have white screen only if game resources are missed / not (properly) installed. You have to install Half-Life game files & patch from Xash3D extras. You've missed or mixed up something, it's no doubt.

Reply Good karma+1 vote
lopesdasilvat5
lopesdasilvat5

but when I tighten on compatibility issues windows says that it is incompatible what I do not understand

Reply Good karma Bad karma+1 vote
lopesdasilvat5
lopesdasilvat5

is windows 7 ultimate 64 bits

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Platforms
Windows
Company
Xash XT Group
Contact
Send Message
Licence
GPL
Release date
Engine watch
Follow
File
Browse
Files
New
Add file
Report
Report
Share
Related Engines
Xash3D Engine
Xash3D Engine GPL
Related Groups
Xash XT Group
Xash XT Group Developer & Publisher
Tags

Xash3D Engine v0.99, build 4097 (outdated) has not been tagged yet.