Description

The Witcher Kings 6.0 for Crusader Kings 2 v2.3.6 -various bugfixes/tweaks/etc

Preview
The Witcher Kings 6.0
Comments
GloriousSkip
GloriousSkip

Is that a typo or does it only work on v2.3.6?

Reply Good karma Bad karma+3 votes
Revan67
Revan67

It should work with anything up to 2.3.6. Let us know if you have any problems.

Reply Good karma Bad karma+1 vote
Heretic01
Heretic01

Could you please add a changelog?

Reply Good karma Bad karma+2 votes
Revan67
Revan67

I will start putting one together for the next update.

Reply Good karma Bad karma+1 vote
Spartaneros
Spartaneros

Magnifique merci je test le mod de suite ! :)

Reply Good karma Bad karma+1 vote
Jureman
Jureman

if you have original crusader kings from steam, right click on it in library, go to betas and select 2.3.6 from droplist. your game will outdate to 2.3.6 in order to play this mod. cheers :)

Reply Good karma Bad karma+3 votes
LyRobert
LyRobert

and i will can return to 2.5.2.2?

Reply Good karma Bad karma+1 vote
Trashmaster21
Trashmaster21

my wont say run when ever i click download.

Reply Good karma Bad karma+1 vote
Raiderdave
Raiderdave

Cant play it :( always crashes when loading into the game after chosing a character. :(

Reply Good karma Bad karma+3 votes
Ahdam
Ahdam

Great mod! Thanks! Only wondering if you happen to know when it will be 2.4.3 compatible? Not a major issue, just checking.

Reply Good karma Bad karma+1 vote
LyRobert
LyRobert

do not work in 2.5.2.2, it's normal?

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.