Description

Raven Keep full release v1.01. A mod for Quake featuring a dark gothic environment, new enemies, weapons and and an intriguing plot.

Preview
Raven Keep Full
Comments
Guest
Guest

This also works with quakespasm spiked?

Reply Good karma Bad karma+1 vote
credfield099 Author
credfield099

No, unfortunately current builds of Quakespasm Spiked do not work with this mod.

The only supported engine is Quakespasm v0.93.2

Reply Good karma+2 votes
Cankler
Cankler

so this will maybe change in the future?

Reply Good karma Bad karma+1 vote
credfield099 Author
credfield099

You can in fact run it under QSS should you choose. But there are certain unresolved bugs. These affect the cut scenes, the way certain models are rendered, etc. So to experienced the visuals as intended only QS .93.2 is recommended.

Reply Good karma+1 vote
Guest
Guest

Hey, Alpha Beta Gamer showcased your mod on YT!

Reply Good karma Bad karma+2 votes
Guest
Guest

Really weird that this mod isnt in quaddicted

Reply Good karma Bad karma+2 votes
TheVidmaster
TheVidmaster

damn it, no darkplaces? Well, gotta switch then...

Reply Good karma Bad karma+1 vote
domjam
domjam

has anyone tested it with darkplaces?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.