Description

Outdated version, including in-game skillwheel made by ThGryphn. Install the mod on top of Tribes of the East + Patch 3.1 (sometimes called 3.01). Always uninstall an older version of the mod before installing a new version.

Preview
Might & Magic: Heroes 5.5 (RC8b)
Comments
Panosftwole
Panosftwole

is it campain compatible ?

Reply Good karma Bad karma+2 votes
mmh55 Author
mmh55

yes all campaigns are included, but if you encounter any issues with new AI in campaign, use MMH55_Utility.exe.

Reply Good karma+3 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

mmh55 Author
mmh55

we currently have no spanish translator

Reply Good karma+1 vote
ari-bagu
ari-bagu

can we use version 3.0?

Reply Good karma Bad karma+1 vote
mmh55 Author
mmh55

no, must be 3.1 (aka 3.01)

Reply Good karma+1 vote
mmh55 Author
mmh55

No it is not, make sure you installed in the right folder and use the utility exe file or map editor.

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.