Description

CK2 3.2.1 or 3.2.2 Official 1.7.0 Version of Guardians of Azeroth.

Preview
Guardians of Azeroth v1.7.0
Comments
Guest
Guest - - 687,512 comments

ワわわわゎー

Reply Good karma Bad karma+2 votes
Zumbak Author
Zumbak - - 299 comments

Omae wa mou shindeiru!

Reply Good karma+2 votes
Guest
Guest - - 687,512 comments

This comment is currently awaiting admin approval, join now to view.

EvvI
EvvI - - 47 comments

Awesome! Good job *-*

Reply Good karma Bad karma+3 votes
Zumbak Author
Zumbak - - 299 comments

Thanks!

Reply Good karma+2 votes
EvvI
EvvI - - 47 comments

BTW, there are any plans to make theocracies playable?
e.g. Tyrande and Velen :/

Reply Good karma Bad karma+1 vote
Zumbak Author
Zumbak - - 299 comments

Yes, but not soon.

Reply Good karma+1 vote
jholst9830
jholst9830 - - 10 comments

Nice job man

Reply Good karma Bad karma+2 votes
kye730
kye730 - - 8 comments

What's new with this update? Just some bugfixes?

Reply Good karma Bad karma+1 vote
Zumbak Author
Zumbak - - 299 comments

Read the patch notes in the description.

Reply Good karma+1 vote
Guest
Guest - - 687,512 comments

Does the mod support all DLC or should i just use the recommended ones?

Reply Good karma Bad karma0 votes
Zumbak Author
Zumbak - - 299 comments

All DLCs.

Reply Good karma+1 vote
BruthaOsas
BruthaOsas - - 1 comments

How do I install this mod?

I have read the readme and extracted the "guardians of azeroth.zip" to documents/.../mod. The plugin of the mod shows up in the CK2 launcher but after I activated it and play the mod doesnt show up at all only the default game.

Can you go into more detail on how to proplerly install it? Is there something specific I have to do with the files? Pls Help

Reply Good karma Bad karma+1 vote
Zumbak Author
Zumbak - - 299 comments

I believe it's resolved here, right?
Reddit.com

Reply Good karma+1 vote
Guest
Guest - - 687,512 comments

I can't play this on 3.3v. Can you help me with that?
I ticked the downloaded azeroth mods before playing but when I start playing, it is just normal CK2 without mod adapted. Do I have to untick all other expansions that work for normal CK2? Or is it just incompatible with 3.31v?

Reply Good karma Bad karma0 votes
Zumbak Author
Zumbak - - 299 comments

It works with 3.3.x. Check the Troubleshooting FAQ at the description, there are possible solutions.

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.