Description

This is the EIF2 vBeta 1.0 . This is a separate module from EIF1 1618AD, savegames and installation are not compatibles. Install it as a new folder under Warband/Modules Folder. Enjoy

Preview
EIF 2: Beta 1.0
Comments
Jatynski Author
Jatynski

Remember; EIF2 is separate MOdule of EIF: 1618 AD. Install apart. Saved games aren't compatibles.

Reply Good karma+5 votes
DarthMalevus
DarthMalevus

l love your work in EIF bro

Reply Good karma Bad karma+2 votes
Kriegtooth
Kriegtooth

Hot damn! :D Thanks for getting it released by tomorrow! :D Nice slightly late birthday present for me :D

Reply Good karma Bad karma+3 votes
TheDazzer
TheDazzer

Awesome!

Reply Good karma Bad karma+2 votes
jer_ying_fd
jer_ying_fd

Are the Polish supposed to have no cavalry?

Reply Good karma Bad karma+1 vote
Guest
Guest

Bug- when your weapon proficency reaches 60 it can no longer be upgraded no matter how many weapon master points you have

Reply Good karma Bad karma+2 votes
maytanoynon
maytanoynon

Error = Charge the enemy (Every Time)
Upic.me

Reply Good karma Bad karma+1 vote
Mladen.
Mladen.

Since appears c++ thing, try to download and install latest c++ visual studio.

Reply Good karma Bad karma+1 vote
Oden_Criteria
Oden_Criteria

How do you recruit national troops instead of only farmers? I joined the United Provinces as a merc, but can still only recruit farmers from their villages. Really enjoying the mod, 17th century is one of my favorite periods in history. Thanks!

Reply Good karma Bad karma+1 vote
Jatynski Author
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.