Description

A patch that fixes many bugs and adds English to the mod

Preview
Demosfen_Update[dev.1.051]
Comments
nikolai.x
nikolai.x

FINALLY. THANK YOU.

Reply Good karma Bad karma+4 votes
dvls
dvls

exactly my thoughts lol

edit. nvm cant install the game...even tho i could install it 2 months ago without any issues...

Reply Good karma Bad karma+2 votes
nikolai.x
nikolai.x

Use CC cleaner to clear its root in your system.
Or go to regedit to delete it.

Reply Good karma Bad karma+2 votes
m5spiritonfire
m5spiritonfire

thank you gonna start playing it right now.

Reply Good karma Bad karma+2 votes
m5spiritonfire
m5spiritonfire

Lua Stack
[14:42:46.676] 0 : [C ] GetAt
[14:42:46.676] Lua state dump locals:
[14:42:46.676] userdata (*temporary) : 'FS_file_list_ex' -> (not implemented)
[14:42:46.676] number (*temporary) : 0.000000
[14:42:46.676] End of Lua state dump.
[14:42:46.676]
[14:42:46.676] 1 : [Lua] ...[demosfen]_dev.1.05\gamedata\scripts\ui_main_menu.script(182)
[14:42:46.676] Lua state dump locals:
[14:42:46.676] userdata self : 'main_menu' -> (not implemented)
[14:42:46.676] userdata flist : 'FS_file_list_ex' -> (not implemented)
[14:42:46.676] End of Lua state dump.

messing with the game options gives instant crash

Reply Good karma Bad karma+2 votes
GyozaRamen
GyozaRamen

Also you can't go above fov 60. Might be nice to have it go above fov 60 as well

Reply Good karma Bad karma+3 votes
smilin
smilin

Great!

Reply Good karma Bad karma+2 votes
JonathanZotack
JonathanZotack

Do the english language have to be set active somewhere? Cuz all the menus are russian after installing this patch. Also can't change anything in options without causing a CTD.

Reply Good karma Bad karma+2 votes
Scocou
Scocou

Language can be changed in the options, look for the "rus" text and change it to the English option. You are probably crashing due to installing the mod somewhere with limited permissions for your user account, i.e. "c:\program files\" or similar. Try to run as Administrator or, more properly, install to the default path (c:\games) and launch as a regular user, your crash should be gone.

Reply Good karma Bad karma+2 votes
JonathanZotack
JonathanZotack

Well every menu is in russian,so can you pinpoint where that thab is?Also I installed on my D drive where every other games and mods are.

Reply Good karma Bad karma+1 vote
Astraxis

Yesss, thank you translators!

Reply Good karma Bad karma+4 votes
Pioneer99
Pioneer99

Как у установить обновление? При запуске пишет что нет игры, все три части я распаковал

Reply Good karma Bad karma+1 vote
Kazemeka
Kazemeka

Oh we praise you, oh ALFA MODMAKER

Thanks for another great version of this epic modpack

Reply Good karma Bad karma0 votes
Klaus000
Klaus000

where to find medical bag? I'm in a mission somewhere in a collapsed tunnel and i can't find that bag
And old problem is back, randoms CTD's when use the m203 grenade launcher

Reply Good karma Bad karma+1 vote
spikesden
spikesden

I've searched all over the cave found nothing yet did you ever find it.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Klaus000
Klaus000

upper comment is mine but i forget to sign in :)

Reply Good karma Bad karma+1 vote
Emmet.Otter
Emmet.Otter

The moment you enter the cave, the middle will have train cars, the left tunnel will have a bunch of items on the floor you can pick up. If you go the right side, the med bag is somewhere between the rocks. Just keep banging the 'use' key. Youll find it.

Reply Good karma Bad karma+1 vote
Module1
Module1

PART2 - PART3 CORRUPTED!!

Reply Good karma Bad karma+1 vote
lilbones59
lilbones59

Whenever i apply the patch to the 1.05 install, it makes my game unplayable, wont even launch. Its playable before the update but as soon as i apply it i get a fatal error "cant setup renderer". Any ideas would be appreciated

Reply Good karma Bad karma+1 vote
maxi666
maxi666

Конченный человек-создатель мода, впрочем мод уверен такой же.

Reply Good karma Bad karma+2 votes
GamersGen
GamersGen

After applying update 1.051 game won't start anymore with log
[15:17:55.131] FATAL ERROR
[15:17:55.131]
[15:17:55.131] [error] Expression : m_setupSelectedRenderer
[15:17:55.131] [error] Function : CEngineAPI::InitializeRenderers
[15:17:55.131] [error] File : I:\Demosfen\src\xrEngine\EngineAPI.cpp
[15:17:55.131] [error] Line : 94
[15:17:55.131] [error] Description : Can't setup renderer
[15:17:55.131]
[15:17:55.131]
[15:17:55.131] stack trace:

Reply Good karma Bad karma+1 vote
GamersGen
GamersGen

Ok, I have found the fix - remove xrRender_R3.dll from bin folder.
Also disable/turn off MSI Afterburner

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.