Description

CK2:AGOT 0.4.2 Checksum: THRN Compatible with: CK2 1.092

Preview
CK2:AGOT 0.4.2 - Windows Installer
Comments
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

kiwityke
kiwityke

For some reason the download just doesn't start for me.

Reply Good karma Bad karma-2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

barncat01
barncat01

any advice on downloading? I have been trying to get a download to start for an hour please advise

Reply Good karma Bad karma-2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

120kg
120kg

I've been having a lot of problems with running mods on my ck2 cuz I'm using a pirated version of the game from SKIDROW. But currently I'm using the first version of the game...will this mod work on the old version, or do i need to struggle on to find a solution?

Reply Good karma Bad karma-2 votes
Guest
Guest

You cannot update your version so it doesn't work with the mod. I'd say you need to buy the game! This is such a good game, with so many hours of gameplay. Support the company please.

Reply Good karma Bad karma+3 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

"E:\Programs\Crusader Kings II\ck2.exe" -mod=mod/A Game of Thrones.mod

That needs to be your shortcut to force a mod to open if launcher doesn't show it. I do recommend you support the developer. It is a great game.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Pethom
Pethom

One moore tiime (like Frank Zappa would have said)!

So here it comes again without being flagged as a guest: This version of the AGoT mod is compatible with CK2 1.092. If I'm using CK2 1.091 will I have a lot of problems or will it work kind of flawlesly? Does anyone know?

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.