Add addon Report PSX Doom fully compatability
Location
Addons
Filename
PSXDOOM_brutal_comp.RAR
Category
Singleplayer Map
Licence
Proprietary
Uploader
prime79
Added
Size
8.93mb (9,368,942 bytes)
Downloads
3,863 (1 today)
MD5 Hash
5b54db9dd5c2d2e05bc25ff19cdd6785
Embed Button
Embed Widget
Description

*** UPDATED 7/23/15 *** I took some time out of one of my days to patch up all that might conflict with brutal doom (terrain like water, etc. will not absorb blood, instead will sit on top, same with casings, bodyparts, etc. no known fix to this yet) it is compatible with your favorite gameplay WAD(s) but specifically has been worked on for brutal doom. It is compatible with any version of brutal doom or submod of brutal doom! Recent Patch Notes: removed menudef as it conflicted with selecting classes. textures updated to accept blood and scarring. End Patch Notes. still working on removing archvile perhaps.

Preview
PSX Doom fully compatability
Comments  (0 - 50 of 74)
prime79 Author
prime79

to let it be known, this is NOT compatable with freedoom (as i have not tested it yet) and as far as i know, unknown zandronum compatibility as well.

Reply Good karma+5 votes
Brutaldoomisawesome
Brutaldoomisawesome

I tried it with my version of it and for zandronium the graphics are bad it's way to dark the colors arn't really good.

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

its doom. its supposto be that way. but anyway, just turn up sector lighting a tad

Reply Good karma+1 vote
Brutaldoomisawesome
Brutaldoomisawesome

I know it is suppose to be that way but it's almost like pitch black and if you want to make it compatable with Zandronum just disable the PSXCAST from the ZMAPINFO on lime 149 where it says include "PSXCAST.TXT" the play it on Zandronum then you'll see what I mean. by it's way to dark and the colors arn't really good. or I could give you a side by side comparison. of GZDoom and Zandronum.

Reply Good karma Bad karma0 votes
Brutaldoomisawesome
Brutaldoomisawesome

Sorry kinda over exagerated with the dark part.

Reply Good karma Bad karma0 votes
scorpeus
scorpeus

I cannot launch it with Zandronum :(
This happens:
Script error, "PSXDOOM.PK3:psxcast.txt" line 1:
Intermission: Unknown top level keyword

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

rambo31377
rambo31377

Good mod. I don't know why other people are having trouble getting it to run with Zandronum, but I haven't had any trouble. Only downside is I don't get any music. Other than that, I like it.

Reply Good karma Bad karma+1 vote
GaySteamBath
GaySteamBath

240p master race

Reply Good karma Bad karma+10 votes
Quaker540
Quaker540

Best. Comment. Ever.

Reply Good karma Bad karma+1 vote
Devianteist
Devianteist

I tried to get this running on my new computer, but it always gives me some kind of Decorate error when GZDoom tries to launch.

Dunno if I did something or what.

Reply Good karma Bad karma+1 vote
Quaker540
Quaker540

Get the latest GZDoom SVN and see what happens; Devbuilds.drdteam.org

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

this. most code of older devbuilds or even the official versions are SO outdated its not even funny. 1.9 final or 2.0 beta will work just fine

Reply Good karma+1 vote
Devianteist
Devianteist

I have been running 1.9 final and get this error. Actually, that's the only Source Port I've been using lately.

Hmm...

Reply Good karma Bad karma+1 vote
Quaker540
Quaker540

1.9 is old too. There's a 2.1 already.

Reply Good karma Bad karma+1 vote
Devianteist
Devianteist

2.x versions don't work on my PC, nor my laptop.

Reply Good karma Bad karma+2 votes
Quaker540
Quaker540

Due to 2.1 and such I sadly had to move on ZDoom. Sucks that they want OpenGL 3.0 now, while basically there's no difference.

Reply Good karma Bad karma+1 vote
brandonvortex1
brandonvortex1

i havent test this version but when i download the new GZdoom it does wanted openGL but solution how i able to play its because i rename the Vid_rendere from 1 to 0

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

what version of brutal doom are you running? any submods or anything?

Reply Good karma+1 vote
Devianteist
Devianteist

Me? I have tried running Brutal DOOM v19 with no submods. I'm guessing it's a problem on my end, either way.

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

mind posting a log here? upload it to media fire. find out how to create a logfile when starting up gzdoom, take that file, pack it, and upload it to Mediafire

Reply Good karma+1 vote
Devianteist
Devianteist

Geez, I should get on here more. I'll do that as soon as I get around to it.

Reply Good karma Bad karma+1 vote
pultow
pultow

Nice

Reply Good karma Bad karma+1 vote
MasochistInBed
MasochistInBed

Prime79, do you have any plans on making this Zandronum-compatible? Mine doesn't open because of some sort of a "SLIME" decor code or something...

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

have you tried updating to the latest Zandronum update? i dont work with zandronum as much as i like it, so if its not compatable from the start, i do not plan to work on it. unfortunately

Reply Good karma+1 vote
prime79 Author
prime79

i removed all features of "slime" or others, it was something conflicting with brutal doom's already featured terrain.wad

Reply Good karma+1 vote
ChroZ
ChroZ

There is no menu nor ambient music and I can't jump.
Also,for some reason I am wounded in main menu,my screen is bloodied and blood dripping can be heard.

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

yeah thats the thing with the main menu, ignore it. youre not supposto be able to jump either, its a lock set within the WAD itself. as for the no menu, i cant tell you honestly, never had that issue. and i kept the ambient music out to reduce filesize for ease of downloading.

Reply Good karma+1 vote
ChroZ
ChroZ

Oh,Alright.Thanks for replying.But is there any way to restore music?

Reply Good karma Bad karma+1 vote
Devianteist
Devianteist

Get the PSX Music wad through this link.
Moddb.com

Reply Good karma Bad karma+3 votes
prime79 Author
prime79

always love it when commenters have some helpful information!

Reply Good karma+1 vote
urizen123
urizen123

Just for clarification - the mod Devianteist linked to is intended as a standalone replacement for the vanilla music, and is not compatible with the PSX TC (due to incorrect filenames, etc) - the music WAD intended for use with the PSX TC is available here; Forum.zdoom.org

Direct link; Mediafire.com

Reply Good karma Bad karma+1 vote
saegiru
saegiru

You can enable jump if you want via the gameplay options menu.

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

nope. it has forced no jump and no crouch

Reply Good karma+1 vote
saegiru
saegiru

Hmm, are you sure? I am almost positive I have enabled it on my end. It is considered "cheating", but GZDoom allows you to enable jump and crouch on forced no jump/crouch wads. I'll have to test it again when I get home.

Reply Good karma Bad karma+1 vote
Guest
Guest

This mod has had no issues for me using GZdoom 1.8.6 until you reach level 24 Hell Beneath. There are supposed to be meat hooks but instead there are 10+ Arch Viles. 2 right in your face to start the level even though they shouldn't exist in psx doom.

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

Archviles were replaced with Meathooks in PSX Doom, i do not plan to change this as it adds some difficulty and makes you attack accordingly

Reply Good karma+1 vote
Guest
Guest

What happened to the music?

Reply Good karma Bad karma0 votes
prime79 Author
prime79

that is part of a seperate addon, easily found through the interwebs

Reply Good karma+1 vote
Guest
Guest

I use GZdoom on a Linux OS, and the build wont work and i dont know where to get openGL, so i could use some help.

Reply Good karma Bad karma0 votes
prime79 Author
prime79

you cant get OpenGL, its part of your computer

Reply Good karma+1 vote
PhillMcHogan
PhillMcHogan

When I got the Build and used it it said it couldnt find openGL

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

your computers hardware is out of date for GZDoom 2.0 (or higher) please stick to GZDoom 1.9, 1.8

Reply Good karma+1 vote
HowWesWasOne
HowWesWasOne

I don't know if this is a problem with Brutal Doom v20 itself, but sectors that are related to teleports seem to drain my health and armor. Or is this a feature?

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

gonna be honest man, i have no clue.

Reply Good karma+1 vote
jon30rockaholic
jon30rockaholic

Why is there no music with this mod? I want the creepy ambient music from the PSX version. Instead, there is no music at all. There is also no music in the menus.

EDIT: Just read in one of your comments that you left the music out due to file size, but I strongly recommend adding it in.

Reply Good karma Bad karma+1 vote
Brutaldoomisawesome
Brutaldoomisawesome

Or you could use my version of it.

Reply Good karma Bad karma+1 vote
jon30rockaholic
jon30rockaholic

I'm gonna try yours out as well.

Reply Good karma Bad karma+1 vote
jon30rockaholic
jon30rockaholic

Can you please add Project Brutality compatibility?

Reply Good karma Bad karma+1 vote
jon30rockaholic
jon30rockaholic

It seems to work with Project Brutality so far. I'm not sure if there are any conflicts with the mods though because I don't know the first thing about DOOM modding, but so far so good.

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

its only maps. it works just fine for anything you wanna play it with. x-weapon, russian overkill, you name it. as long as it doesnt replace maps :P

Reply Good karma+1 vote
Brutaldoomisawesome
Brutaldoomisawesome

But yours really isn't much compatible with BDV20 yet. You still need the doom classes where you can play as the modern FPS, or the classic player classes or have splash effects for it. If you want me to I can send you the splash script I modified and the terrain file for the optional footstep sounds.

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

loading BD after usually fixes all issues like that. loading before tends to cause issues. ill go through and see whats wrong and then see what i can do once i get back from going out.

Reply Good karma+1 vote
Brutaldoomisawesome
Brutaldoomisawesome

Nope all the textures and flats are named differently in the PSX Version, and trying to load it after brutal doom doesn't get you the Classic player class it will start you off as the normal brutal doom but if you load it before then you'll get the choices for Modern, Classic, or Random.

Reply Good karma Bad karma+1 vote
prime79 Author
prime79

AH thank you. i fixed it. menudef was conflicting, will work on getting it uploaded now

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Addon
Browse
Addons
New
Add addon
Report
Report
Share
Community Rating

Average

9.3

8 votes submitted.

You Say

-

Ratings closed.

Related Mods
Related Games
Doom
Doom First Person Shooter
Related Groups
Team Brutal
Team Brutal Fans & Clans with 33 members