Description

hello everyone, I made a patch or a fix for Juraszka's:Less Accurate NPC's with worse vision mod, I was playing anomaly, had a crash and found it was Juraszka's mod and the problem was with a line within his script, so I took-out the problemsome line that was causing the crash (you still have to download Juraszkas mod first then overwrite his script file with my script fix) (( example where it is located at, from my own directory: C:\Games\Anomaly\gamedata\scripts)) big ups to Juraszka for the creation of his mod, if you don't want enemies cod-like hitscanning you with a shotgun from 2000 yards then this is the mod for to download. (do note that the enemies can still dome you in a decent range but not at an unforgiving range) ((also I think the A.I companions actually perform better and benefit from this from personal testing, as my bandit companions that I have gotten from sultan, didn't all die or just simply have one left in my party)) (very artistic rendition of event included)

Preview
LESS ACCURATE NPC WITH WORSE VISION script fix now also updated to 1.5.1 with RC
Comments
bvcx
bvcx

You just swapped hardcore AI aim with normal, so when people will disable "Hardcore AI Aim" option they will get a hardcore AI aim....when they enable it they will get normal npcs....
In addition, you removed half of the code that isn't related to NPC's aim, why? xd

Reply Good karma Bad karma+5 votes
OttoVonLitmarck Author
OttoVonLitmarck

does it? I mean, I don't really know, I don't *think* it does, but I also have never played hardcore so I can't really be sure or know the difference here, though again I didn't make the mod itself, so when you say "you just" here it's Juraszka, *he* made the mod (I only did this fix *and provide, only* this fix because it was causing a crash), I also quite literally stated why up above: there was a line of code that made the game crash (when I fast travelled, that bit I didn't include because of space) so I removed said line of code, it was just a simple line of code that caused it, and I did not remove half "of the code" .

Reply Good karma+1 vote
tcmx
tcmx

You play with this file on 1.5.1 ? If so you shouldn't. Check what Juraszka changed on his mod page, and then compare his file with the one from version 1.5.1.

Reply Good karma Bad karma+2 votes
OttoVonLitmarck Author
OttoVonLitmarck

And why shouldn't I, if I may ask? I've just checked a couple of them and they look fine to me. if so *which* of these changed "files" he did should I look for *specifically* on why I shouldn't use this?

Reply Good karma+1 vote
tcmx
tcmx

The file you uploaded, it's not based on 1.5.1 version of Anomaly. Maybe you should update Juraszka's mod to 1.5.1 rather than manipulating and using his olds files.

Reply Good karma Bad karma+2 votes
tcmx
tcmx

Its not that complicated since Juraszka show what files and lines he modified on the mod page, you should try this rather than uploading a fix for an old file of a mod not even up to date. Sorry if I have bad english.

Reply Good karma Bad karma+2 votes
OttoVonLitmarck Author
OttoVonLitmarck

I personally haven't had any *other* problems with running it on the 1.5.1 (and the RC builds') version(s) regarding anything *else* to be fair in it, besides that single instance that I had or mentioned earlier, during my play-tests with his mod (that and i'm downright terrible at creating scripts, myself, atleast for anomaly I am, so thats kinda outta the question, not to even mention i'd also be treading on thin ice here and i'd have to contact him to give me the go ahead if I was *even good* at creating the new scripts for his mod to update it in the first place) honestly I find just releasing the script crash fix, to fix that singular, only problem in it (that I have found). to be well, good enough and just fine personally. call me lazy but I just don't see the point, gutting/updating every single thing in it, if it works just fine as is besides that one and (seemingly) only thing wrong. but anyways i'll still try to fiddle around with it on my spare time and see, no gurantee's

(edit: while re-looking once more at juraszka's mod page, there's really no changes from looking at 1.5.0 ((the version where Juraszka worked on with his mod)) to 1.5.1, the vanilla values that Juraszka showed on his page, are quite literally the same to 1.5.1's i've checked all the vanilla 1.5.0 to 1.5.1 values (by looking at them in the unpacked files for 1.5.1 and comparing them to the 1.5.0 originals that were on his mod page to see if the devs of anomaly changed anything in-between versions, and I can almost gurantee you here, that they haven't touched them since 1.5.0, so there's really nothing *to actually change* barring in mind I may or may not
work on to change what bvcx brought it earlier

Reply Good karma+1 vote
tcmx
tcmx

Juraszka only edit a certain part of bind_stalker_ext, if you want to use his tweaks on 1.5.1, copy that part, who is shown on the mod page, in the 1.5.1 vanilla file. So the file will be up to date. Actually if you compare his file with the 1.5.1 one, you will see many difference in the code apart from the part he modified. Hope you understand me.

Reply Good karma Bad karma+2 votes
tcmx
tcmx

I guess you are not using winmerge, cause I am and from what I can see there is many differences apart from the part he modified, so dont say me that there is no changes between 1.5.0 and 1.5.1 bro, I can even send you the file with his tweak up to date if you want, but he just inverted the values for hardcore AI aim, nothing important.

Reply Good karma Bad karma+2 votes
OttoVonLitmarck Author
OttoVonLitmarck

I got you, ye I did notice the bind_stalker script was a little different, so what I have done now is that I have now pasted Juraszka's changed values/tweaks into the new 1.5.1 script, that's what you did mean here to say, right? will replace the .rar of one here on moddb with the new one.

Reply Good karma+2 votes
tcmx
tcmx

Yes but the "con:execute" need to be renamed "exec_console_cmd" in order to be like the vanilla file. Glad I can help, you should verify the other files of his mod but I dont think they can cause issues, bbut maybe some values can differ idk.

Reply Good karma Bad karma+1 vote
OttoVonLitmarck Author
OttoVonLitmarck

yes, see tcmx, I got the 1.5.1 vanilla version of the bind_stalker script and I inserted Juraszka's tweaks into it so it has that already done, that's what I meant. Also thank you

Reply Good karma+1 vote
tcmx
tcmx

Nice, like this you're sure the game won't crash :)

Reply Good karma Bad karma+2 votes
OttoVonLitmarck Author
OttoVonLitmarck

hehe, im pretty sure now! :)

Reply Good karma+1 vote
Juraszka
Juraszka

JURASZKA WORSE NPC VISION AND ACCURACY FOR ANOMALY 1.5.1
Moddb.com

Reply Good karma Bad karma+2 votes
OttoVonLitmarck Author
OttoVonLitmarck

Hey Juraszka, did you just release these recently? do you want me to take this down or make it obsolete or still keep this keep up?

Reply Good karma+1 vote
Juraszka
Juraszka

I only noticed your release after my update. If you want, You can keep it - your contain lower values than in my actual so someone could like this more than my.

Reply Good karma Bad karma+2 votes
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.