Post download Report abuse STC - Release BETA - Hotfix II
Jun 8th, 2013
1.26mb (1,317,061 bytes)
4,497 (1 today)
Embed Button
Download now

Hotfix for use on the TNG Content Update ONLY, will not patch earlier versions of the mod!

As is the order of things a release brings with it more bugs, and hundreds of people are going to find more bugs than just the dev team!

This Hotfix corrects the errors reported since the release of the TNG content update, please post any further bugs on the forum!

If you are wanting to install Continuum from scratch then here is a helpful guide (all of them are links) for which order and what item you will need to do the install:

  1. Homeworld 2
  2. Homeworld 2 - 1.1 patch
  3. Star Trek Continuum - Release Beta
  4. Star Trek Continuum - Content Update
  5. This File!
Preview Image
STC - Release BETA - Hotfix II
Post comment Comments
880Zero Jun 8 2013 says:

Not the Dominion! :O

+1 vote     reply to comment
Zepher87 Jun 10 2013 replied:

I keep having trouble with them. Only once did they send me ships and right after I was broke and they started attacking. Even when I have like a million resources they take all my money and I get nothing and I cant undo it.

+2 votes     reply to comment
Guest Jul 4 2013 says:

This comment is currently awaiting admin approval, join now to view.

Niburo1990 Sep 17 2013 says:

I have everything installed as you guys said but there is still some problems- some effects are missing such as warp effects and ship icons. Is this normal? When my ships are exiting warp all I see is this huge bunch of white squares appear and disappear. Could this be because of directX?

+1 vote     reply to comment
Stargazer42 Sep 17 2013 replied:

No, this is not normal. What graphics card are you using?

+2 votes     reply to comment
Niburo1990 Sep 18 2013 replied:

The now ancient Siluro FX5200+ , but that thing could keep up with all effects from HW2 and its mods, BSG Fleet Commander too. DirectX9c is installed. Also, some Klingon weapon effects are missing too. I installed 1.1 then Beta, then the update and a Fix II over my HW2. I will try to reinstall the mod and see what will happen.

+1 vote     reply to comment
Guest Dec 5 2013 says:

This comment is currently awaiting admin approval, join now to view.

Post a Comment
click to sign in

You are not logged in, your comment will be anonymous unless you join the community today (totally free - or sign in with your social account on the right) which we encourage all contributors to do.

2000 characters limit; HTML formatting and smileys are not supported - text only

Report Abuse
Report download
MD5 Hash
Related Groups
Continuum Corp
Continuum Corp Developer & Publisher with 8 members