This mod is the third installment of the Mods I have made It contains some of the iconic BFME1 campaigns It also splits Harad and Mordor ( Harad is mixed with Wild Faction) It is based on Power Of the Ring / Rise of the Pheonix / Rise Of harad

Description

Main Mod final version date uploaded - 21 ST MAR 2021 I had time to fix minor issues with the mod So this is the FINAL VERSION If I have any more fixes , I will upload and change date If you discover Bugs please let me know

Preview
JUS SAURON  BFME2 MOD
Comments
robeni2050
robeni2050

thank you

Reply Good karma Bad karma+2 votes
JUS_SAURON Author
JUS_SAURON

Latest version uploaded 2nd May 2020

Reply Good karma+1 vote
JUS_SAURON Author
JUS_SAURON

Latest version uploaded 3rd May 2020

Reply Good karma+1 vote
robeni2050
robeni2050

good mod

Reply Good karma Bad karma+1 vote
Guest
Guest

My load after a save does not work. It comes up error loading game c, users, roaming etc. Any help please? :)

Reply Good karma Bad karma0 votes
JUS_SAURON Author
JUS_SAURON

Fresh Install , Latest BFME2 patch
LotrBfMe2-65542-english.exe
I am not sure about saves , I just play until win
Never tested that bit

Reply Good karma+1 vote
JUS_SAURON Author
JUS_SAURON

LAST UPDATE 2ND AUG

Reply Good karma+1 vote
JUS_SAURON Author
JUS_SAURON

LAST UPDATE 4TH AUGUST
BALANCE AND TESTING

Reply Good karma+1 vote
JUS_SAURON Author
JUS_SAURON

LAST UPDATE 9TH AUG 2020

Reply Good karma+1 vote
JUS_SAURON Author
JUS_SAURON

VERSION UPDATE :23 AUG 2020

FIXED CRASING WHEN LOADING SAVED GAMES
TESTED CAMPAIGN FOR CRASHING

Reply Good karma+1 vote
JUS_SAURON Author
JUS_SAURON

VERSION UPDATE :31 AUG 2020

FIXED CRASHING WHEN LOADING SAVED GAMES
TESTED CAMPAIGN FOR CRASHING

Reply Good karma+1 vote
JUS_SAURON Author
JUS_SAURON

update 21 Sept 2020

Reply Good karma+1 vote
neily1
neily1

Excellent. Thank you! :)

Reply Good karma Bad karma+1 vote
JUS_SAURON Author
JUS_SAURON

LAST UPDATE :26th Sept 2020
Fixed a bug with BFME1 Map Buildpolts

Reply Good karma+1 vote
Guest
Guest

[URGENT]
For some reason, the 1.09 patch will not work with this mod. I have the new BFME2 Patch Switcher with the dropdown bar for different heights. It works okay with patch 1.06 but not 1.09. I put the patch on 1.09 and then click on the JUS MOD shortcut on the desktop. It pops up the splash screen of patch 1.09 then it gives an error box. It crashes and gives me this error box that contains:

Data\INI\Default\Water.ini:
Duplicate MACRO names.
SUB_HERO_HEALTH.
7 addresses:
(unknown)(0): game.dat+241550 Debug::PostStaticInit+3390
(unknown)(0): game.dat+2294796
FXParticleSystem::DefaultModuleKey<0>::operator=+209278
(unknown)(0): game.dat+2325810
GameClientRandomVariable::setRange+15179
(unknown)(0): game.dat+6460555 Xfer::operator==+119787
(unknown)(0): KERNAL32.DLL+129577
BaseThreadInitThunk+25
(unknown)(0): ntdll.dll+423412
RtlGetAppContainerNamedObjectPath+228
(unknown)(0): ntdll.dll+423364
RtlGetAppContainerNamedObjectPath+180

Because of the severity of this error the game will now exit.

I do not know why this is the case. I love this mod. I recently got back playing this game and installed it on my new windows 10 pc. I remember all the cool abilities, units, and buildings that were modified. I play it again, and I forgot how close the camera is to the ground. I can't play like this for an RTS game anymore. I want to be able to play on 1.09 with widescreen capabilities so I can see all those cool units like the Witch-King and more than two buildings at a time. It allows me to strategize better and move units. I hope this mod can be run on 1.09. That is what I am guessing since the last post was from Sep. 26th 2020 and the description says JAN 23rd, 2021. Again, please let me know the issue here through the game crash error box. I am going to try to uninstall everything and use the disk instead. If it is not on my end and this mod is not for patch 1.09, I would consider updating it to that. I am sure the other people using this mod would enjoy it a lot better too!

Again, great work on the mod just needs widescreen support

Thanks

Reply Good karma Bad karma0 votes
JUS_SAURON Author
JUS_SAURON

I never used 1.09 patch , as I believe 1.06 is the last official patch
I will look into it

Reply Good karma+1 vote
Mord_Sith84
Mord_Sith84

Why can't I get your ROTWK version to work? I keep on getting an error saying "expected signed integer file" game crash when I click on the icon.

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Tags