Savage 2: A Tortured Soul takes the best of the FPS, RTS, and RPG genres and blends them seamlessly into an extremely addictive and complex experience. Anyone who's seen the game in action knows that each match is full of possibilities for epic moments and amazing displays of skill and strategy. Take the reigns as your team's commander from an overhead RTS perspective with superior strategic insight -- or join them on the field from a mixed action RPG and FPS view with a wide array of powerful classes and carve your path to victory.

Forum Thread
Savage2 and Xubuntu (Games : Savage 2: A Tortured Soul : Forum : Help and techsupport : Savage2 and Xubuntu) Locked
Thread Options
Jan 14 2012 Anchor

Ok, I don't want to spam the Comments, so let's continue here.
As I said:

Mobai wrote: console.log was empty, so I uploaded crash_2.1.0.1_02.log:
It's a really old PC, Pentium4, 1GB RAM, ATI Radeon 9600, Xubuntu Oneiric
I could try it later on my Netbook, Athlon II Neo X2, 2GB RAM, ATI Mobility Radeon HD 4225, Fedora 16
And what is (in my opinion) really strange: Yesterday , there was Debian installed (which I replaced because it was extremely slow, I don't know why), and it worked! Ok, 0.25 FPS, but it worked!

Edited by: Mobai

Jan 14 2012 Anchor

1GB RAM will be a real problem to play this game.

You can also modify file to contain the appropriate LD_LIBRARY_PATH statement.

We've submitted an update to Desura, but they have to approve it and it isn't clear when that will happen.

Jan 14 2012 Anchor

Its the lower limit for small maps. Had it run on a 6800GT, Pentium 4 with 2 gig, worked on mid / lower mid settings.

I would say you used a different driver in debian. Did you install the closed source ati driver?

Jan 15 2012 Anchor

AFAIK, my graphic card is not supported by the closed source driver...

Jan 15 2012 Anchor

Realy? Ok this could be the problem. You need full compatible OpenGL 2.0 (in hardware and software) graphic card to play the game.

Do you have a windows install? Can you check if its working there?

Jan 15 2012 Anchor

I have an old XP installation, but I installed the proprietary driver there (some yeras ago, when it was a "high-end" card). Should I try it?

BTW: When I wanted to replace Debian with Xubuntu, I installed Ubuntu 11.04, upgraded and installed Xfce.
On Natty, I tried it - and it worked. But why? Why did it work on Debian Wheezy and Ubuntu Natty, but not on Xubuntu Oneiric?

Jan 15 2012 Anchor

Try it on Windows XP please.

Maybe Natty and Oneiric have a different version of the driver...

Jan 15 2012 Anchor

Hm, there is no windows... I propably removed it :)
But that doesn't matter, the game runs on my hardware... but not on my software ;)

This "error" (that the game won't open) seems to be common on Ubuntu Oneiric, someone in another Thread said:

Someone wrote: i did this and it doesnt work also when i select the desura app closes and nothing happens
i have ubuntu 11.10 btw

If we don't find a solution: On which ditribution does it work?

Jan 15 2012 Anchor

I play it on ubuntu 10.4 with closed source amd/ati driver. It works without problems :). But its not the desura and the vanilla version from

Jan 19 2012 Anchor

Hm. Ok. On my Netbook with Fedora 16 it seems to work (I just stole 4GB of RAM from my server), but on the upper half of the screen I don't have the "world" but it's just white. If I look down, I don't see it any more. In the... "tactical"... mode, I don't see the ground, only the hills/mountains.

Jan 19 2012 Anchor

This is is a known issue with certain kernel/video card combinations:

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.