A beat 'em up/platforming/fighting game hybrid with an electro style. You can smack guys, attach their parts and get their abilities!

Forum Thread
Unable to play game (Games : Megabyte Punch : Forum : Errors/bugs : Unable to play game) Locked
Thread Options
May 19 2013 Anchor

I just saw Jesse Cox's video on this game, and after realizing that it reminds me of Smash Brothers I went ahead and bought the game through the Google Wallet option you have on your front page.

However, after starting the game up, I either just get to the menu, or I make it to the splashscreen saying "Thank you for pre-ordering" and then it immediately crashes.
Making me completely unable to play the game.

I'm playing on Win 7, and I get the "GetThreadContext" error message when it crashes.

Turns out, if it I run the game in Windows 98/ME Compatibility mode, it runs perfectly flawless.
I got no idea how, or why, but messing around with that made it seemingly work.

May 19 2013 Anchor

That's odd man, you are the first one reporting an actual crash! Congratulations! :)
Anyway, did you try reinstalling the game? Do you install the game in the default directory (program files/reptile/megabytepunch) did you do something with the registry or did you moved folders including the game around?

I'm glad that it's working in 98 compatibility mode, still it should work in normal windows 7 mode as well.

May 19 2013 Anchor

Haha well I'm glad to be the first then, I guess!

Yeah I reinstalled it a couple of times, always in the default directory aswell.
I neither touched the registry nor did I move folders.

Only messed around with the compatability modes, which seems to have worked as I just managed to play the past hour and a half away.

Damned additcting game, I must say!

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.