Forum Thread
"Could not load library client" driving me insane (HL2) (Forums : Support : "Could not load library client" driving me insane (HL2)) Post Reply
Thread Options
Sep 17 2017 Anchor

HL2 mods literally do not work for me. This is one of the most ANNOYING problems I have ever encountered with any game. Mods simply REFUSE to work no matter what I try. I've scrolled countless pages of google, found many """""""solutions""""""" that don't work at all for me but have somehow worked for other people with the same problem. I have Source SDK Base 2006, 2007, and 2013. 2013 is set in beta upcoming, as most mods require. I follow the readme of every mod, their instructions on the mod's post, still nothing wants to work. I've only gotten two mods to work somehow just by pure luck. I've tried verifying game cache, tool cache of the SDK bases, restarting steam, deleting HL2 bins, verifying again, and nothing works. I've even tried repairing steam service. I get the update window (even though it's a mod), I click play, it shows the intro, then the loading screen, and the game crashes with "Could not load library client. Try restarting. If that doesn't work, try verifying game cache." Great instructions right? I've tried contacting the mod creator but he takes a while to respond. Even he said he doesn't know how to fix that. So if there's any definite or possible fix let me know.

The mod I'm currently trying to install is Terminal 7 created by Nooke (these apply to most other mods I've tried to install)
-gameinfo.txt has the correct id in it.
-bin has client.dll and server.dll
-I made NO modifications to the mod folder whatsoever
-I've tried various launch options (-dev, -autoconfig, and the likes)
-I have HL2, EP1, and EP2
-Mod was installed correctly (the mod's main folder is in sourcemods)
-I've reinstalled all related games
-Two mods actually worked with no issues (PTSD and Random Quest)
-Tried putting related games in beta mode along with the SDK bases if possible

Specs (if that could relate to anything although I doubt it):
Windows 10 64 bit
Intel Core i7-4770K 3.50 GHz
Geforce GTX 950

Please don't say "I have the same problem" because that won't help unless you fixed it before and it worked afterward.

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.