Add file The Last Days of the Third Age 3.6 for M&B 1.011
Location
Files
Filename
TLD_3.6.7z
Category
Full Version
Uploader
Swyter
Added
Size
675.77mb (708,593,633 bytes)
Downloads
2,887 (3 today)
MD5 Hash
96121f428eb40c7cde65c6a942d8f0d7
Embed Button
Embed Widget
Description

The Last Days of the Third Age 3.6 for the original Mount&Blade; 1.011 (i.e. not Warband). This is a standalone version that works as our base package, to get the latest features and fixes please regularly patch it with the latest nightly at tldmod.github.io.

Preview
The Last Days of the Third Age 3.6 for M&B 1.011
Comments
Swyter Author
Swyter

For help, support, bug reports, or discussion, please visit us on:

Discord:
Discord.gg

Steam Workshop:
Steamcommunity.com

Reply Good karma+2 votes
Guest
Guest

This mod is awesome! Thank you for maintaining it for M&B and not just Warband

Reply Good karma Bad karma+1 vote
Edranda
Edranda

Hey. I'm not sure if I should ask this on the discord. How do I fix when it says it can't open certain texture files?

Reply Good karma Bad karma+2 votes
jewzboy
jewzboy

If you find out can you let me know because i have the same problem

Reply Good karma Bad karma+2 votes
Swyter Author
Swyter

Here's what we've added to the download page.

Note: Because of the stringent memory requirements, the only supported variant of the original game is the latest, DRM-free «enhanced version» [1], with Mount&Blade;.exe patched as large-address aware [2].

The Steam version will not work out of the box. Alternatively, you can download a pre-patched executable from here [3] and replace the one in the Steam folder. It is the same shareware version, with one (LAA) bit toggled. No other changes.

Without doing this the game will either crash at startup complaining about texture files or it will crash after surpassing ~1460 MB of RAM.

[1]: Mbrepository.com
[2]: Techpowerup.com
[3]: Raw.githubusercontent.com

Reply Good karma+1 vote
Guest
Guest

Hi. I've done everything on this list and the game still doesn't work.

Reply Good karma Bad karma+1 vote
Swyter Author
Swyter

Try replacing the game's executable with this one from the Enhanced version and with LAA checked: Raw.githubusercontent.com

Put the dinput8.dll from the TLD folder next to it, in the root folder. Works for me.

Reply Good karma+1 vote
Guest
Guest

um i haveing a error where it says hlsl data handles [5] is not vaild

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

File
Browse
Files
New
Add file
Share
Related Games
Mount & Blade: Warband
Mount & Blade: Warband Role Playing
Related Groups