Description

version 1.4 comes with a lot of changes. Make sure to read the whole description

Preview
swbf2 remaster 1.4
Comments  (0 - 50 of 75)
DarthSkotia
DarthSkotia - - 98 comments

Let's take a look at this!

Reply Good karma Bad karma+3 votes
/TheWolf
/TheWolf - - 845 comments

What would happen if i installed 1.3 patch after installing this?
BTW will it automaticly uninstall 1.4 beta too?

Reply Good karma Bad karma+2 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

beta will be removed, too.
Well i'm not sure what files were changed by uop, but properly the game will no longer start

Reply Good karma+1 vote
Guest
Guest - - 695,351 comments

What's up with the 64 Ai per team option when it doesn't work?

Reply Good karma Bad karma0 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

already does? you can increase the number up to 64 in the settings

Reply Good karma+1 vote
FireseekerDE
FireseekerDE - - 7 comments

Doesn't work for me. Set it to 64 Bots per team but there are still ~32 bots

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

well i increased the number you can set. i haven't count the bots ingame. I'm an interface modder, not game. idk what else limits the bot count

Reply Good karma+2 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

well i got the feedback, that there are 64 bots. just the final stat screen shows 32. But who needs 64 bot stats?

Reply Good karma+2 votes
FireseekerDE
FireseekerDE - - 7 comments

Ah, sorry. Didn't read your reply. Sorry if my comment sounded a bit harsh, it wasn't meant that way... I really appreciate your Work, it's a nice Mod!

Ok i will see later... Thank You one again!

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

no problem, i really didn't test this feature, i was satisfied when i saw the 64 in the settings

Reply Good karma+2 votes
RolfDew
RolfDew - - 85 comments

Does the latest version of the mod allow you to add 64 bots per a side too? Sorry if I'm mistaken.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 695,351 comments

when i try getting into a map, the game crashes

Reply Good karma Bad karma0 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

check you gamedata/data/_lvl_pc folder. is there a remaster folder? are there gc or user scripts?
remove those and rerun the installer

Reply Good karma+1 vote
Guest
Guest - - 695,351 comments

i just tried it now and it still happens

Reply Good karma Bad karma0 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

what did you try? did you remove the unused user/gc scripts and install remaster 1.4 again?

Reply Good karma+1 vote
Guest
Guest - - 695,351 comments

i moved them to a folder on desktop so they weren't in the lvl_pc folder

Reply Good karma Bad karma0 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

and is it a stock map that crashes or a custom?
interface works? How about galactic conquest/mulitplayer?

Reply Good karma+1 vote
Guest
Guest - - 695,351 comments

This comment is currently awaiting admin approval, join now to view.

Guest
Guest - - 695,351 comments

just a little update i tried to reinstall the game from scratch then ran the installer again and im still having the same problem

Reply Good karma Bad karma0 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

ok, i never had those problems. CD or DVD version?
Can you please put this into your GameData folder, start a game running this debugger and send me the log?
Dropbox.com
The log is in the same folder of the exe, or in the virtual store folder
C:\Users\username\AppData\Local\VirtualStore\Program Files (x86)\LucasArts\Star Wars Battlefront II\GameData

Reply Good karma+1 vote
Guest
Guest - - 695,351 comments

i have the cd version and in the log it was talking about missing custom gc files from 0 to 9 but found 10

Reply Good karma Bad karma0 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

that's fine. can you send me the log? upload to a cloud, send me a pm, or contact me on discord?

Reply Good karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

solved on discord
Solution was to clean old stuff from the virtual store folder

Reply Good karma+1 vote
Guest
Guest - - 695,351 comments

How do you change the UI HUD of the Health and Stamina bar?

I really do not like that change on this version. It looks odd to see the length of the bar small and a health number when it is not really that important to read.

The colour of the bar when it shows your health is very clear, and the health number over it just blocks the way.

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

No way unless you know how to mod

Reply Good karma+2 votes
MsChromaticKiss
MsChromaticKiss - - 74 comments

Ever since I installed Remastered I've loved it and I'm so happy for a 1.4 update, this has been one of the few mods I've actually been excited to have a new release as this mod is exactly what I've been dreaming for since I messed around with resolutions 3 years ago. Good on you for another release! I hope the future versions will bring even more to this old gem.

Reply Good karma Bad karma+4 votes
CommanderCody1
CommanderCody1 - - 7 comments

I usually have no issues with the installment process but this "gamedata" is getting me confused right now... Thing is is that it should automatically find the folder but it doesn't and when I do it tells me otherwise...

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

Autodetect works for DVD version, i think not for steam.
Well show me screenshot of your folder pick

Reply Good karma+1 vote
CommanderCody1
CommanderCody1 - - 7 comments

How do I do that again? Thx for reply my friend...

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

Just in case someone else run into the same problem, we continued this in PMs.
A first problem was that the game's exe was not named "BattlefrontII.exe". But it continued, that even UOP installer did not work. So not finally solved, but looks like a more general problem. For all others haveing this problem, make sure you pick the folder with the game's executable. It needs to be named "BattlefrontII.exe" Not "battlefrontII.exe" or "game32.exe". Some mods such as piracy ultimate pack or saga edition seem to do changes with that.

Reply Good karma+1 vote
Clone50
Clone50 - - 8 comments

Does this work with the shaders patch ?

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

the latest version should work well. i know there was a version that changed core.lvl. that won't work

Reply Good karma+1 vote
HELP!!!
HELP!!! - - 4 comments

Can someone help me? When I start the game, over time the ai start to disappear. I am not sure if this is the mod causing it or not. Is there any fix?

Reply Good karma Bad karma+2 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

well there were others with the same problem, but nobody shared his solution. i guess it's something with additional ai hero scripts, or things like this

Reply Good karma+1 vote
HELP!!!
HELP!!! - - 4 comments

I figured out you need to restart the mission again.

Reply Good karma Bad karma+1 vote
Guest
Guest - - 695,351 comments

This version support multipayer with gameranger?

Reply Good karma Bad karma0 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

yes

Reply Good karma+1 vote
slayer1552
slayer1552 - - 11 comments

Setting the bot count to 64 doesn't seem to do anything. Looks like it's still spawning 32. I tried counting arrows on the minimap, didn't really look like 64. I tried adding up the unit counts of all the available units. Looked to be about 32 or a little below.

Disabling Award Weapons seems to no longer work.

Each unit on the spawn selection screen only shows 3 of the 4 items its carrying instead of the 4 that it used to due to the increased HUD size.

I like the new ingame HUD though so good job on that.

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

it can be a memory pool limit that isn't fixable.

yes i have the same problem with the award weapons

the box size is fixed, so you have the choice between 4 lines that are not readable, or 3 lines that are

Reply Good karma+1 vote
United_Snakes53
United_Snakes53 - - 2 comments

Unfortunately when I try to run a map all my teammates despawn and I'm the only one there? In fact everyone despawns.

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

well there were many with this problem, but till today nobody gave me a feedback how they solved it.

Reply Good karma+2 votes
RolfDew
RolfDew - - 85 comments

If it helps, I had the problem of ai not spawning, so I just removed the hero user scripts and galactic conquest scripts (that I had from other mods) and everything worked fine after that. Perhaps the hero user script from the other mod caused a conflict.

Reply Good karma Bad karma+2 votes
Guest
Guest - - 695,351 comments

help please my installer has an error stating i must select the game data folder but does not give me the ability to select a folder to install to

Reply Good karma Bad karma0 votes
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

download the latest version, it let's you select the folder

Reply Good karma+1 vote
Awebby
Awebby - - 1 comments

I downloaded this mod today and, it worked for about an hour until I decided to save and quit on galactic conquest. When I did that the screen turned black and stayed that way. Now when I try to open either remastered or classic the same thing happens and the screen just turns black. What should i do?

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

pretty sure you overwrote the settings file. go and delete it from savegames

Reply Good karma+1 vote
DarthSkotia
DarthSkotia - - 98 comments

The same happened to me, I even reinstalled the game but it didn't help at all.

Reply Good karma Bad karma+1 vote
[GT]Anakin Author
[GT]Anakin - - 1,033 comments

when you reinstall the game, you don't delete the SaveGames files. Go and delete the remastersettings file from the SaveGames folder. Steam user in addition have the problem that if you activate cloud sync, the corrupted file will be restored. So make sure it's actually deleted

Reply Good karma+1 vote
DarthSkotia
DarthSkotia - - 98 comments

Yeah I figured it out on my own already, thanks!

Reply Good karma Bad karma+1 vote
Guest
Guest - - 695,351 comments

This comment is currently awaiting admin approval, join now to view.

Guest
Guest - - 695,351 comments

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.