Description

SuperDuperQuake 3.21 Patch. SuperDuper Quake 3.2 is required. New weapons: Fists and chain lightning. Bots! Impulse 100. HD textures included for DirectQ and Darkplaces: sdquake\textures\progs. Put them in sdquake\progs for DarkPlaces Extract to your sdquake directory and overwrite all.

Preview
SuperDuper Quake 3.21 Patch
Comments
hondobondo Author
hondobondo

thanks for your support!

Reply Good karma+2 votes
Massao_Quaker
Massao_Quaker

Right in the crotch!

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.