Description

Official release of Submachine level version 1.0 for Duke Nukem 3D - this version comes with intended snapshot of EDuke32 required to play it. Mostly added for backwards compatibility and avoiding any collisions with potential future releases of EDuke32.

Preview
Submachine - version with intended EDuke32 snapshot
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.