Description

The mod. you know you want it. you can even play as a demon!

Preview
Zion v07
Comments  (0 - 50 of 88)
FPSNation
FPSNation

Hopefully the monsters got fixed. *crosses fingers*

Reply Good karma Bad karma+1 vote
doomlover3
doomlover3

This mod is not working for me.

Reply Good karma Bad karma+1 vote
kaadmy
kaadmy

What happens when you load it?

Reply Good karma Bad karma+1 vote
patogameplays
patogameplays

if you load with zandroum 2.1 dont work, with gzdoom 1.8.10 or more, or zand 3.0

Reply Good karma Bad karma+1 vote
Guest
Guest

i cant install gzdoom on my linux only zandroum but still 2.1 version i cant get the 3.0 where the hell can i updated t the 3.o version?? please!!!!!

Reply Good karma Bad karma0 votes
springtrapguy08
springtrapguy08

Boi, It's under the Development Builds section. Just scroll down.

Reply Good karma Bad karma+1 vote
doomlover3
doomlover3

When I load it, it just loads vanilla Doom.

Reply Good karma Bad karma+1 vote
Guest
Guest

Are you loading it from the archive because, then you need to always have the archive open when playing. this is because when you drag the mod on top of doom the archive will uncompress the file and store it in temp memory.

Reply Good karma Bad karma+1 vote
doomlover3
doomlover3

You there?

Reply Good karma Bad karma+1 vote
SAHZALPABAEL Author
SAHZALPABAEL

what source port are you using? what else are you loading with the mod? are you doing it right? plz dont spam

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

DOOMArx
DOOMArx

how do i install the mod

Reply Good karma Bad karma+1 vote
springtrapguy08
springtrapguy08

Stupid, stupid stupid. (https://www.youtube.com/watch?v=DZaKe-N0m14)

Reply Good karma Bad karma0 votes
xMobilemux
xMobilemux

Hi I'm having this issue:
Orig10.deviantart.net

How can I fix it cause I really wanna play this mod?

Reply Good karma Bad karma+1 vote
xMobilemux
xMobilemux

Nevermind I figured it out, but is there a way to get this to work with the Brutal Doom mod?

Reply Good karma Bad karma-1 votes
DOOMArx
DOOMArx

how did you fix it im haveing the same problem

Reply Good karma Bad karma+1 vote
kaadmy
kaadmy

You have to use GZDoom, there's the multiplayer and co-op versions for Zandronum for a reason.

Reply Good karma Bad karma+1 vote
perefalcon
perefalcon

GZDoom is the only engine you can use doom4 mod in best quality because GZDoom is how doom4 mod meant to be played :P

Reply Good karma Bad karma+2 votes
Sanderkiller
Sanderkiller

i get this error too plz help how can i fix it

Reply Good karma Bad karma+1 vote
perefalcon
perefalcon

@Sanderkiller, you need gzdoom's latest version that suit your computer the best and you have to load zionv7 mod after all the files such as Doom2.wad, Doom.wad, tnt.wad, plutonia.wad are in the file directory as well

Reply Good karma Bad karma+1 vote
springtrapguy08
springtrapguy08

NO. However their is a DOOM 4 weopon mod.

Reply Good karma Bad karma+1 vote
Mp18
Mp18

you need zandronum 3.0

Reply Good karma Bad karma+1 vote
doomlover3
doomlover3

I'm using GZDoom, and I'm not loading this mod with any other mods.

Reply Good karma Bad karma+1 vote
SAHZALPABAEL Author
SAHZALPABAEL

gzdoom gave me many problems,try zandronum 3.0

Reply Good karma+1 vote
Thezombinator
Thezombinator

Will you make this compatible with project brutality

Reply Good karma Bad karma+1 vote
DOOMArx
DOOMArx

how do i install the mod for zandrum

Reply Good karma Bad karma+1 vote
perefalcon
perefalcon

@DOOMArx, this is gzdoom or zdoom mod.. it won't be compatible with zandronum

Reply Good karma Bad karma+1 vote
KarnTheSlayer
KarnTheSlayer

This Works with Zandronum

Reply Good karma Bad karma+1 vote
Guest
Guest

I think the blue smoke in the Gauss Cannon is so cartoony & static and look like edited in sai (sorry)
┬┐Could you add a better one? And remaining dynamic lights in some shoots, beams and pickups

Reply Good karma Bad karma+2 votes
Guest
Guest

There is posibility to add some kind of brigthmaps? I been played Proyect brutality, so could you
Replace the berserk as and "Demon" rune to turn into a Revenant like in PB



For last, there is already the weapon upgrade system? Triple chaingun, modded shotgun, etc.

Reply Good karma Bad karma+3 votes
@TheCrimsonFucker
@TheCrimsonFucker

It's all cool but when we will see the full support of dismemberment from the Brutal Doom?

Reply Good karma Bad karma+1 vote
SAHZALPABAEL Author
SAHZALPABAEL

when doom 2016 comes out

Reply Good karma+3 votes
@TheCrimsonFucker
@TheCrimsonFucker

It's a joke or what? Why do you need new doom 2016? You just need classic doom, with classic weapons(fists/chainsaw, pistol, shotgun/SSG, chain gun, plasma gun and BIG ************* GUN) but in new design and gore. And it's all, no fatalities, no shity weapon modification or multiplayer weapon.

P.S. Your sprites just amazing, this is best the part of this mod, good job.

Reply Good karma Bad karma-4 votes
SAHZALPABAEL Author
SAHZALPABAEL

BD does classic doom monsters good enough,were bringing doom 4 to doom 2 so that means we need the best sprites from the game and we cant do that with e3 footage sorry. for now im working on a simple file that enables BD compatibility but it will have issues because this is not a BD mod,its a doom mod

Reply Good karma+4 votes
shawnvirgo30
shawnvirgo30

Hi, can you please fix the hud for 4:3 resolutions? It seems the same hud from 16:9 is used, which causes the corners to be cut

Reply Good karma Bad karma+1 vote
shawnvirgo30
shawnvirgo30

I'm using 800x600 resolution btw

Reply Good karma Bad karma+1 vote
SAHZALPABAEL Author
SAHZALPABAEL

press - and + to find the best hud,i set up the default hud to be 4:3

Reply Good karma+1 vote
vlad0904
vlad0904

When i load it i see Script error, "ZIONv07.pk3:decorate" line 6:
"weapon.bobrangex" is an unknown actor property but i use zandorum 3.0

Reply Good karma Bad karma+1 vote
SAHZALPABAEL Author
SAHZALPABAEL

obviously not,make sure you have the latest Zand 3.0 or use Gzdoom

Reply Good karma+2 votes
Tritnew
Tritnew

Can't wait to see some actual good weapon rips, but I really like this mod! I might make a Deathmatch or TDM for It as well, either It be Included In the Mod or It be a whole thing on It's own.

Reply Good karma Bad karma+1 vote
TJGSASQUATCH
TJGSASQUATCH

i have the latest versions of Gzdoom and Zand and i also get the "ZIONv07.pk3:decorate" line 6:
"weapon.bobrangex" is an unknown actor property

Reply Good karma Bad karma+2 votes
MightyKitten
MightyKitten

Are you using Zand 3.0? That ran it perfectly for me.

Reply Good karma Bad karma+2 votes
elculebra
elculebra

Where can I download Zand 3.0?

Reply Good karma Bad karma0 votes
mtencza
mtencza

demon transformations can't crouch or fit in tight spaces.

Reply Good karma Bad karma+7 votes
Andrei93
Andrei93

Thank you so much for this mod.It works perfectly with gzdoom and zdl.What I find really cool is the very fluent and smooth animations and the models look really good.You guys did a great job.Now all we need are the monster models from Doom 4 and we are done. :)

Reply Good karma Bad karma+2 votes
DOOMArx
DOOMArx

Im haveing problems starting this mod evrytime i start is it says
Script error, "ZIONv07.pk3:decorate" line 6:
"weapon.bobrangex" is an unknown actor property

Reply Good karma Bad karma+1 vote
DOOMArx
DOOMArx

can someone help me

Reply Good karma Bad karma+1 vote
MightyKitten
MightyKitten

Download Zandronium 3.0 from here:
Zandronum.com
This will run it.

Reply Good karma Bad karma+1 vote
Guest
Guest

Oh yeah doom 4 for low end pc thanks alot!

Reply Good karma Bad karma+2 votes
MightyKitten
MightyKitten

This mod is great! It adds a whole new feeling to Doom, and runs perfectly! And to all who don't know how to play it or what source engine to use, Zandronium 3.0 is a great one to use.

Reply Good karma Bad karma+1 vote
SAHZALPABAEL Author
SAHZALPABAEL

zand 3.0 is the best :D

Reply Good karma+4 votes
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.