Description

The Infinite War has escalated into an Eternal Conflict. Pick your faction and rejoin the battle with new units and technologies to unleash upon your galactic foes. Eat their lunch! Now compatible with patch 1.26.

Preview
DLC: Eternal Conflict v0.984
Comments
DocCap
DocCap

This mod is not compatible with Myths mod support minimod.
Can that be a reason of why my pc crashes the game only when I'm using your mod?

Reply Good karma Bad karma+2 votes
Bastilean Author
Bastilean

Unload the mod. Verify the intergrity of your game cache. Load Eternal Conflict. Start SC2. You don't need mithy's mod loaded with Eternal Conflict. It's built in.

Reply Good karma+2 votes
Guest
Guest

what is with moddb.... forever unable to download because there "are no avaliable mirrors"

Reply Good karma Bad karma0 votes
Camo_Hunter8
Camo_Hunter8

make an account and you won't need mirrors most of the time.

Reply Good karma Bad karma+6 votes
BlickEnforcer
BlickEnforcer

When ever I launch supreme commander 2 with the mod manager, and start a game up, it crashes during the loading screen. Please help.

Reply Good karma Bad karma+2 votes
ciamek
ciamek

"Unhandled exception has occurred in your application. if you click Continuse,the application will ignore this eror and attempt to continue.if you click quit,the application will close immediately.

Input string was not in a correct format."

That shows up when i try to add this mod to mod menager.

Reply Good karma Bad karma+2 votes
Guest
Guest

Me and my friend get a desync about an hour in always. until then it works fine

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.