Description

The Legendary Complex Addon LCA is a WAD by Legendary that further introduces additional monsters and weapons to Complex Doom. LCA also features legendary variants of Doom's bestiary, which are extremely challenging versions of their kinds and may randomly appear throughout a level by replacing existing spawns. Upon killing a legendary monster, the player may be rewarded with legendary weapons, ammunition or powerups.

Preview
Complex Doom LCA Legendary Complex Addon LCA-1.5.9.6
Comments  (0 - 50 of 68)
ericeagle
ericeagle

It doesn't work. It crashes when trying to use it with complex doom. Some ******** about "inventory"

Reply Good karma Bad karma+8 votes
styd051 Author
styd051

you have it launched me with what software? Normally it works if you use zandronum

Reply Good karma+2 votes
DieHardjagged
DieHardjagged

Any Update of how i get it working?
When i start it together with Complex i always get
"Script error, "lca-v1.5.8.pk3:actors/weapons/assaultshotgun.txt" line 14:
Unexpected 'AssaultSG-Marine' in definition of 'Assault Shotgun"
As Error message.

Reply Good karma Bad karma+3 votes
RG.ITA
RG.ITA

Try latest GZDOOM or Zandronum 3.0-alpha-161030-2038

Reply Good karma Bad karma+2 votes
ledernierrempart
ledernierrempart

it doesn't work with gzdoom 2.3.2, same error for me:

Script error, "lca-v1.5.8.pk3:actors/weapons/assaultshotgun.txt" line 14:
Unexpected 'AssaultSG-Marine' in definition of 'Assault Shotgun '

Reply Good karma Bad karma+2 votes
RubberTunes
RubberTunes

GZDoom 2.4.0 is newest. grab it and try again!

Reply Good karma Bad karma+1 vote
ledernierrempart
ledernierrempart

fatal error.

Reply Good karma Bad karma+4 votes
goanna678
goanna678

you need to use an older version

Reply Good karma Bad karma+2 votes
Sgt.Denison
Sgt.Denison

same but 4.3.3

Reply Good karma Bad karma+1 vote
D3MONSLAY3R101
D3MONSLAY3R101

It worked for me on GZDoom v3.2.5

Reply Good karma Bad karma+3 votes
VGmaster9
VGmaster9

I used v3.3.2 and I got this:

Script error, "lca-v1.5.9.5.pk3:actors/weapons/assaultshotgun.txt" line 7:
Unexpected 'AssaultSG-Marine' in definition of 'Assault Shotgun '

Reply Good karma Bad karma+2 votes
ItsChristian
ItsChristian

works on GZDoom v3.8.2

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Sonidorock
Sonidorock

Every time I try to run it I get an error: "Script error," lca-v1.5.8.wad: actors / weapons / assaultshotgun.txt "line 11:
Replaced type 'Assault Shotgun' not found in Assault Shotgun "

Reply Good karma Bad karma+4 votes
Guest
Guest

So I'm getting the script error and I'm playing on the Zandronum 3.0 alpha, help?

Reply Good karma Bad karma+2 votes
SpartanofApproval
SpartanofApproval

I keep getting these errors when trying this addon:

Attempt to get invalid state Death from actor DevastatorLightningRedSpawner.
Tried to register class 'ComplexDoomPlayer' more than once.
Script error, "lca-v1.5.8.pk3:actors/monsters/cerebralcardinal.txt" line 479:
class 'FusionNuke' is not compatible with 'Inventory'
Script error, "lca-v1.5.8.pk3:actors/monsters/cardihilator.txt" line 488:
class 'FusionNuke' is not compatible with 'Inventory'

Using GZDoom 2.2.0.

Reply Good karma Bad karma+5 votes
Guest
Guest

why legendary weapons cant hurt legendary enemies?

Reply Good karma Bad karma+1 vote
Guest
Guest

iv tried to get this to work in every way. iv had no problem running the normal complex any advice?

Reply Good karma Bad karma+1 vote
michellefranceshilla
michellefranceshilla

I tried it with GZdoom 2.4.0 and I got a very fatal error from Zdoom.

Reply Good karma Bad karma+2 votes
SwiftyMagee
SwiftyMagee

To anyone having issues with Complex Doom and the Legendary Complex Addon, both seem to load up fine with the latest version of Zandronum. If I try to use the wads in the latest version of GZDoom, GZDoom itself seems to crash to desktop.

Just using Complex Doom works fine in GZDoom, so it seems like the Legendary Complex Addon is not compatible with the GZDoom source port. Until it's made compatible, try using Zandronum with these wads. If you get any script errors with Zandronum, try using the latest stable build and not a dev build (although I did just try it with a dev build of Zandronum and it ran fine).

If you're still getting errors getting it to run, make sure to load the Complex Doom wad first (complex-doom.v26a2.pk3) and the Legendary Complex Addon second (lca-v1.5.8.pk3). If you don't know how to adjust load order, the easiest way is to use the ZDL launcher (https://zdoom.org/wiki/ZDL) and manually adjust load order through that program.

EDIT: If you want the latest version of the Legendary Complex Addon, go to this Zandronum thread: Zandronum.com. It seems like there was an update to the wad earlier today.

Reply Good karma Bad karma+3 votes
lohne-troian
lohne-troian

I'm using the latest version of Zandronum, launched with ZDL, and I still get

Script error, "lca-v1.5.9.5.pk3:actors/items/legendaryarmor.txt" line 24:Unexpected '200' in definition of 'LegendaryArmor'

Reply Good karma Bad karma+4 votes
SwiftyMagee
SwiftyMagee

Just a happy addition to my last comment...it seems like the latest version of the Legendary Complex Addon works with GZDoom 2.4. I just tried it with both a stable build of GZDoom and today's dev build and they both work.

So if you're having issues with Complex Doom and the Legendary Addon, try using the latest build of GZDoom and download the most up-to-date version of Complex Doon and the Legendary Addon from here: Zandronum.com. You can also obviously use Zandronum and probably have none of the previously posted issues with these wads.

Reply Good karma Bad karma+3 votes
OmegaZX0000
OmegaZX0000

where can i download the Zandronum version??
lca-v1.5.9.4-zan2.1.2.pk3 (the Zandronum link is broken Zandronum.com)

Reply Good karma Bad karma+2 votes
BLAZING_DUST
BLAZING_DUST

I'm not here to complain about crashing or whatever, I'm here to complain about the mod itself. First off, make the legendary monsters actually difficult and fun to play against. All I had to do to defeat a legendary monster was saving and peeking corners to shoot it until it died. Then, I acquired some legendary powerup and the legendary plasma rifle, whatever it was called. Then I encountered a legendary imp. I used the powerup I gathered from that legendary monster (zombie), saved and proceeded to shoot the legendary imp. Then, whenever the powerup would expire, the game would crash. I've tried like 3 times again and the result is no different. I'm using GZDoom 3.1.0.
Here's a few tips:
- Make the legendary monsters chase the player and not run away from the player.
- Fix that powerup crash bug.
- Balance out between OP guns and OP endurance in the earlier levels, then later on make monsters have both OP guns and OP endurance.
- The dramatic music is annoying IMO, make an option to disable it instead of having it to replace the level music until the monster is killed.

Reply Good karma Bad karma+2 votes
Smashingoose
Smashingoose

I can't play it. I installed it and the latest version of Zandronum and it still won't allow me to play it. Itg keeps popping up errors as other in the comment section said. I go and click on it and it asks me which wad I want to play. Click the wad, click play and then error. Any suggestions, videos. Anything helpful would be be appreciative.

P.s. I can play it in the zandronum doomseeker multiplayer maps but not in regular mode

Reply Good karma Bad karma+2 votes
Hipermedic911
Hipermedic911

HI i Found a solution for this mod you need zandronum version 2.1.2 and it Will Work

Reply Good karma Bad karma+2 votes
Danteclone3
Danteclone3

I Keep getting this error and it wont run.
Script error, "lca-v1.5.9.5.pk3:actors/weapons/assaultshotgun.txt" line 7:
Unexpected 'AssaultSG-Marine' in definition of 'Assault Shotgun '
Im seriously new to Zandronum and wont use anything else (as i dont feel like using anything else lol im lazy)
And i dont know crap about load orders
anyone got a fix for this?

Reply Good karma Bad karma+2 votes
Guest
Guest

could you change it into a pk3 file so it works? thanks!

Reply Good karma Bad karma+1 vote
Danteclone3
Danteclone3

then do it yourself idiot

Reply Good karma Bad karma+1 vote
Danteclone3
Danteclone3

For anyone who gets error assault shotgun, use ZDL and put load oder in this
Complex doom thing
LCA

Reply Good karma Bad karma+3 votes
Kewin0
Kewin0

Hola broder novan a tirar mas monstros y armas legendarias

Reply Good karma Bad karma+2 votes
BladeDragon9
BladeDragon9

Hey guy update you gzdoom new version 3.5.0 right now zdoom.org

Reply Good karma Bad karma+3 votes
BladeDragon9
BladeDragon9

Link : zdoom.org/index

Reply Good karma Bad karma+3 votes
Guest
Guest

Lca just doesnt work :/ Tried everything, Zdoom, GZdoom, ZDL load order and none of it works, fix this stuff before making it public.

Reply Good karma Bad karma+2 votes
Kewin0
Kewin0

Cada ves guardo y miero para volver a aparecer se queda congelado todo en delta touch

Reply Good karma Bad karma+2 votes
Guest
Guest

Apoco sí sirve en android?

Reply Good karma Bad karma+1 vote
Nick357r
Nick357r

It shows updated Nov 10 2018, what was updated?

Reply Good karma Bad karma+1 vote
styd051 Author
styd051

yes

Reply Good karma+1 vote
szwejo5
szwejo5

i have error

Script error, "lca-v1.5.9.6.pk3:actors/weapons/assaultshotgun.txt" line 7:
Unexpected 'AssaultSG-Marine' in definition of 'Assault Shotgun '

Reply Good karma Bad karma+2 votes
styd051 Author
styd051

did you use zandronum 3.0?
did you load the files in order?
. complex-doom.v26a2.pk3
. lca-v1.5.9.6.pk3

Reply Good karma+1 vote
szwejo5
szwejo5

still don't work

Reply Good karma Bad karma+1 vote
szwejo5
szwejo5

it will have update or something to fix that issue ?

Reply Good karma Bad karma+1 vote
AlexeiStukov
AlexeiStukov

I downloaded and saved to my GZDoom folder, when I drag complex doom to GZDoom.exe and try to play everything is vanilla. This is the first mod I downloaded so maybe I did something wrong?

Reply Good karma Bad karma+1 vote
clockworkreaper
clockworkreaper

"Script error, "lca-v1.5.9.6.pk3:actors/weapons/assaultshotgun.txt" line 7:
Unexpected 'AssaultSG-Marine' in definition of 'Assault Shotgun'"
^ pops up everytime i try to load this. im using zandronum 3.0 170901-1140. i also tried it on gzdoom 3.7.0 (modern) and it still wont work. same error.

Reply Good karma Bad karma+1 vote
clockworkreaper
clockworkreaper

i fixed it. i had a bad load order.

Reply Good karma Bad karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

wtfismyface
wtfismyface

doesnt work for me. Can you make a guide?

Reply Good karma Bad karma+2 votes
wtfismyface
wtfismyface

Script error, "randommons-v1.2.4-server.only.pk3:actors/weapons/bhgenerator.txt" line 554:
Unexpected ';' in definition of 'PBlackHoleDark'

Reply Good karma Bad karma+2 votes
AlexeiStukov
AlexeiStukov

Hello everyone, Im not the most tech savy person, but I downloaded the mod and tried dropping it onto GZDoom and nothing changes, am I missing a step?

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.