Description

first episode of Operation : Mallard this is the first episode, and basic training map. more content to be released ASAP. works best with duke nukem 3d 1.5 with eduke32. not tested on World tour or other later releases/ports

Preview
Operation Mallard
Comments
Mikko_Sandt
Mikko_Sandt - - 116 comments

Crashes immediately after the second splash screen. There's nothing terribly useful in the txt file:
2.7520s INFO| VPX: GLSL mode
2.7520s INFO| VP8 timing stats (mean, max) [ms] for 11 frames:
2.7520s INFO| read and decode frame: 0.09, 1
2.7520s INFO| 3 planes -> packed conversion: 0.00, 1
2.7520s INFO| upload and display: 0.09, 1

Reply Good karma Bad karma+2 votes
Flamin_weenie Author
Flamin_weenie - - 5 comments

hey, wich splashscreens would that be? the opening cinematics?

Reply Good karma+1 vote
Mikko_Sandt
Mikko_Sandt - - 116 comments

Right after the "A J & M Production" screen.

Reply Good karma Bad karma+1 vote
Flamin_weenie Author
Flamin_weenie - - 5 comments

normaly this should display the duke3d splash screen with the duke3d logo flies in. there is nothing special going on at that point so im quite puzzled as to why it should crash at that point. especially considering the a J&M production part is deffed in art, and the intro logo video is new.. the only thing that starts at that point would be the music. strange, but indeed there is not much info in that TXT file, is this from the eduke32.txt log file?

Reply Good karma+1 vote
Mikko_Sandt
Mikko_Sandt - - 116 comments

Yes, it's from the log file. I even tried to disable the splash screens via preload.con but it still crashes.

Reply Good karma Bad karma+1 vote
Flamin_weenie Author
Flamin_weenie - - 5 comments

very strange, there is no reason for it to do that since everything at that point should be already loaded. could you send me the entire log file?

Reply Good karma+1 vote
Mikko_Sandt
Mikko_Sandt - - 116 comments

runtime src|
0.0690s INFO| Started at 2023-03-10 19:30:12.559
0.0711s INFO| EDuke32 r10066-6ae3c8317
0.0728s INFO| Built May 17 2022 08:02:17, GCC 10.0.0, 64-bit
0.0739s INFO| Using directory I:/SteamPelit/steamapps/common/Duke Nukem 3D/gameroot/
0.0753s INFO| Using directory I:/SteamPelit/steamapps/common/Duke Nukem 3D/gameroot/addons/dc/
0.0766s INFO| Using directory I:/SteamPelit/steamapps/common/Duke Nukem 3D/gameroot/addons/nw/
0.0781s INFO| Using directory I:/SteamPelit/steamapps/common/Duke Nukem 3D/gameroot/addons/vacation/
0.0800s INFO| Using directory I:/SteamPelit/steamapps/common/Ion Fury/
0.0817s INFO| Application parameters: -grp mallard.zip
0.0828s INFO| Using directory C:/Operation_Mallard/
0.0907s INFO| Checking for updates...
0.3773s INFO| Connecting to Eduke32.com
0.4685s INFO| Current version is 20120522
0.4691s INFO| No updates available.
0.4703s INFO| OS: Windows 10 (build 10.0.22000)
0.4708s INFO| Initialized 1ms system timer
0.4715s INFO| CPU: AMD Ryzen 5 3600 6-Core Processor
0.4720s INFO| Initializing SDL 2.0.20
0.6741s GFX| Detecting video modes for display 0 (Generic PnP Monitor)...
0.6896s INFO| Searching for game data...
1.2968s INFO| Using DUKE3D.GRP as main data file.
1.3000s INFO| Loaded mallard.zip
1.3032s CON| Compiling: GAME.CON (200787 bytes)
1.3080s CON| Including: cons/defs.con (46332 bytes)
1.3110s CON| Including: cons/user.con (69932 bytes)
1.3382s CON| Including: cons/solspeak.con (9872 bytes)
1.3394s CON| Including: cons/ww2.con (124504 bytes)
1.3406s CON| cons/ww2.con: At top level:
1.3412s WARN| cons/ww2.con:90: symbol 'FLAMEBOSS' already used for variable.
1.3420s WARN| cons/ww2.con:141: symbol 'PANZER' already used for variable.
1.3459s CON| Including: cons/weather.con (5018 bytes)
1.3466s CON| cons/weather.con: In actor 'SNOWMAKER':
1.3473s WARN| cons/weather.con:281: empty 'ifaction' branch
1.3480s CON| Including: cons/weapons.con (149876 bytes)
1.3522s CON| Including: cons/nature.con (1090 bytes)
1.3530s CON| Including: cons/preload.con (4858 bytes)
1.3538s CON| Including: cons/damagewalls.con (1115 bytes)
1.3564s CON| GAME.CON: In state 'lizthinkstate':
1.3570s WARN| GAME.CON:6052: found 'else' with no 'if'
1.3587s WARN| Found 4 warning(s), 0 error(s).
1.3605s CON| Compiled 484912 bytes in 56ms
2.1433s INFO| Initialized 96.0M cache
2.1451s INFO| Loading duke3d.def
2.1681s ERR| File models/ark.png not found
2.1873s INFO| Definitions file 'duke3d.def' loaded in 42 ms.
2.8154s INFO| Loaded DUKE.RTS
2.8163s INFO| Initializing console...
2.8893s INPT| No game controllers found.
2.8931s INFO| Loading clip map _clipshape0.map
2.8950s INFO| Loaded clip map.
2.9016s INFO| Executing settings.cfg
2.9079s INFO| Executing autoexec.cfg
2.9374s GFX| Setting video mode 1920x1080 (32-bpp fullscreen).
3.0157s GFX| Enabling ATI FBO color attachment workaround.
3.0161s GFX| OpenGL driver: AMD Radeon RX 5700 XT 4.6.0 Compatibility Profile Context 22.8.2.220819
3.0162s GFX| OpenGL context: version 4.6
3.0260s GFX| Refresh rate: 144.00Hz.
3.2624s INFO| Opened texturecache as cache file.
3.2626s INFO| Cache contains 200 bytes of garbage data
3.2627s ***| Initializing Apogee Sound System
3.2827s ***| Using SDL WASAPI driver on Steam Streaming Microphone
3.2831s ***| Initialized sound at 44.1 KHz stereo with 64 voices
3.2831s ***| Initializing MIDI driver: AdLib OPL3 emulation
3.3080s INFO| VPX: 25 frames / 1 seconds (25.000 fps).
3.9386s INFO| VPX: GLSL mode
3.9386s INFO| VP8 timing stats (mean, max) [ms] for 16 frames:
3.9386s INFO| read and decode frame: 0.31, 4
3.9386s INFO| 3 planes -> packed conversion: 0.00, 4
3.9386s INFO| upload and display: 0.00, 0

Reply Good karma Bad karma+1 vote
Flamin_weenie Author
Flamin_weenie - - 5 comments

what might help is removing the autoexec.cfg file, it could potentially set a wrong render mode, maybe. i dont see anything strange so im puzzled to be honest.

i've tried many different settings, but i cant get the game to crash at launch. even in classic mode where it doesnt render the new videos it still goes to the correct splash screen.

Reply Good karma+1 vote
Mikko_Sandt
Mikko_Sandt - - 116 comments

Nah, that's one of the first things I tried.
But two things:
-It actually does launch in classic mode, but obviously suffers from some severe performance issues
-I tried the game on my old work laptop with an integrated GPU and there the game actually works in Polymost. I just tossed the folder via my network to the laptop's temp folder and launched it, so the contents are exactly the same.

Reply Good karma Bad karma+1 vote
Flamin_weenie Author
Flamin_weenie - - 5 comments

i found that deleting the texture cache might fix the issue, i had a weird thing where it would freeze during loading out of the blue with no error messages, deleting th cache seems to fix it. i hope its related to the same thing.

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Tags