Post news RSS RadioPhobia + OGSR

Today we present an adaptation of the modernized game engine OGSR for radiophobia modification. Modified engine OGSR is an advanced functionality of various settings collected from different parts of the game STALKER and materials from various developers modifications.

Posted by on


Today we present an adaptation of the modernized game engine OGSR for radiophobia modification. Modified engine OGSR is an advanced functionality of various settings collected from different parts of the game STALKER and materials from various developers modifications. For users not engaged in modding set of basic settings in the game menu, which can be adjusted at will, for those who have experience in modding and who are developing their modifications, there are additional tools in the form of configuration files in which you can activate various options, create configuration and texture files and thereby increase the basic set of different gameplay settings In the game engine already installed options such as 3d lens operating at an increase in sights, thermal imager, able to use ammo from tactical vests, setting knives and different instruments in separate inventory slots, additional sound effects when switching fire modes or by increasing the zoom in the optical instruments and many other options found in the various versions, improving the graphics, edited the shaders and much more. The video materials show only the basic adaptation of the engine, without any global changes to the configuration files and the models themselves.


Trailer


Gameplay


Weapon





Comments
Stachelhaut
Stachelhaut

How the hell do I get this to run? Always getting out of memory crash before even starting.

Reply Good karma Bad karma0 votes
Ferr-um Author
Ferr-um

PC upgrade

Reply Good karma+1 vote
Stachelhaut
Stachelhaut

I don't think that my PC is too weak to handle this - all hardware is up-to-date.

The Error I get is:
____
Expression: error handler is invoked!
Function: handler_base
File: c\projects\ogsr-engine\ogsr_engine\xrcore\xrdebugnew.cpp
Line: 393
Description: std: out of memory

See log file and minidump for detailed information
Press OK to abort execution
___

(The Folder "c\projects\ogsr-engine\ogsr_engine\xrcore\xrdebugnew.cpp" does not exist on my pc)

The way I installed:
1. Clean instal of Shoc 1.06
2. set Gamedata = true
3. Install radiophobia 2a + fix
4. deleted gamedata-config and gamedata-scripts and bin
5. copied the assembly

tried to run xrEngine -> instant crash

Any idea how to get this working?

Reply Good karma Bad karma+1 vote
CheekySp
CheekySp

add -steam to launch parameters (in shortcut). This is so stupid. I actually spent 5 hours trying to get the game to run and it turned out, "out of memory" error was misleading. GOG and Steam versions apparently need this switch to run OGSR. Stupid, stupid, stupid.

Reply Good karma Bad karma+2 votes
Stachelhaut
Stachelhaut

Thanks man. Though I use the retail version it still needs the - steam line added to the shortcut. Weird, but works :D

Reply Good karma Bad karma+1 vote
Nicopathe
Nicopathe

Hi,
Can you tell us precisely how To install OGSR on top of radiophobia so that it can actually work ?
Thanks

Reply Good karma Bad karma+1 vote
Ferr-um Author
Ferr-um

assembled version of the modification with the game engine OGSR - Stalker-mods.clan.su

Reply Good karma+1 vote
Nicopathe
Nicopathe

Thanks Ferr-um !

Reply Good karma Bad karma+1 vote
Ferr-um Author
Ferr-um

Version of the game engine is not the last unfortunately, there is no free time to update, but the mod is stable on OGSR. Also, there is a small problem with the textures of sighting marks, as the game engine uses them a little differently, unlike the original version of the game, but this can be fixed by replacing them with the appropriate size according to the resolution of the monitor. You will need to register on the site to have access to download links. The modification is launched in the bin_x64 folder, double-click on the xrEngine file.exe

Reply Good karma+1 vote
CheekySp
CheekySp

Crashes randomly due to NPC grenade script. Apparently xrs_grenade.script is glitching and I had 4 crashes in couple hours. Thus, it's unplayable, unfortunately.

Reply Good karma Bad karma+1 vote
Ferr-um Author
Ferr-um

Perhaps you need to install vanilla animations for the grenade, I met this bug in OWR 3, after installing the vanilla version of the grenade model and animations, this error was not present.

Reply Good karma+1 vote
vukhacthanh
vukhacthanh

it's not in english. HElP ME STALKER!!

Reply Good karma Bad karma+1 vote
Ferr-um Author
Ferr-um

The modification is Russified, but you may need to switch in the localization file, to ENG, so that the language becomes English, I do not remember exactly, since the project was made a long time ago.

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

News
Related Groups
S.T.A.L.K.E.R. - MODS
S.T.A.L.K.E.R. - MODS Fans & Clans with 29 members