Post news RSS Problems in recent release builds

Update your installation of The Traveling Fox with the new builds!

Posted by on

Due to several problems in the builds for windows and linux which caused the game to crash either at start or in the first level, we've re-uploaded fixed builds to the 17.10.0 release. If you got your application prior to October 8. and the application didn't work for you try to download the new version.

We are very sorry for this inconvenience.

Currently we are also working on Debian packages for Linux users until then if you're using ubuntu or any other snap enabled distribution, you should try the traveling fox

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.