Post news RSS Game Requirement Changed!

Valve has changed the game requirements for Modular Combat!

Posted by on

Valve has changed the game requirements for Modular Combat! You will now be able to play if you own one of the following Valve games:

  • Half-Life 2
  • Portal
  • Portal 2
  • Left 4 Dead
  • Left 4 Dead 2

P.S. Valve's Tom G. is responsible for this change. Please send him kind regards (but not by email as that would likely annoy him, simply reply here and when enough nice posts are made, ill link him).

Comments
Zeltrax
Zeltrax

Thanks man. Hopefully this makes the community bigger!

Reply Good karma Bad karma+4 votes
necron15
necron15

Awesome.

Reply Good karma Bad karma+3 votes
dragon99919
dragon99919

<3

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.