Post news RSS Empire ai bug

I think the Empire losing its ai is due to the pirates having access to the Empire research building, or possibly just a result of giving the pirates ai at all...I will test an alteration to the way pirates tech upgrade to see if that restores the Empire's ai. Development of this mod is back, but it will only be a little bit of work until I decide whether to continue to fix problems in this mod.

Posted by on

E_Research_Center is key in ways the game uses to determine whether the Empire should upgrade its tech, I think that by giving pirates access to building it it made the game decide not to use Empire ai altogether. I will begin by reexamining the files related to tech upgrading, I think simply giving the pirates a new tech building that is a copy of E_Research_Center I can fix the problem. Pirates probably wont upgrade their tech but at least the Empire will do what it should. Expect an update sometime next week.

Comments
Loganw1 Author
Loganw1

Actually that should be E_Research_Facility. I havn't looked at the xmls in a while.

Reply Good karma+1 vote
Loganw1 Author
Loganw1

Didn't work, but I did fix a minor coding mistake that made pirates unable to build the E_Ground_Research_Facility (I got the name wrong twice!), I think I'm just going to make the pirates more like rebels as far as tech upgrading. I tried that first but the slice ability wasn't working.

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.