The Ultimate Apocalypse mod team proudly presents to the Dawn of War: Soulstorm players and fans, an eagerly awaited and packed with epic content game experience, the Ultimate Apocalypse mod! Imagine a mod featuring massive Warhammer 40,000 battles where all 9 races in Soulstorm (and more!) have a chance at epic victory. A mod where there's no shortage of all new units, buildings, abilities, and even titans! A mod where there's nearly no limits holding you back. It's all about all out, massive war. Wanna nuke your enemies? You can. Gloriously epic titan duels are your thing? Ultimate Apocalypse has you covered. Not only that, but Ultimate Apocalypse is continuously tested to ensure the epic battle experience it delivers remains unique while being completely awesome. Thanks to you (yes, you!) and everyone playing, Ultimate Apocalypse has been steady within the top 20 ranked mods for years.

Report (OUTDATED) Ultimate Apocalypse - Patch v1.86.3
Filename
Ultimate_Apocalypse_-_THB_v1.86.3.exe
Category
Patch
Uploader
Lord_Cylarne
Added
Size
116.03mb (121,669,124 bytes)
Downloads
29,710 (2 today)
MD5 Hash
53f95df6216556325a941ae19ae518cb
Embed Button
Embed Widget
Description

Ultimate Apocalypse - The Hunt Begins Patch (for version 1.86+)! REQUIRES full installation of 1.86 as this is a patch! If it does not work in multiplayer with others, then uninstall as you ignored errors during install process. Click "read more +" for additional download mirrors and install instructions.

Preview
(OUTDATED) Ultimate Apocalypse - Patch v1.86.3
Comments  (0 - 50 of 138)
Lord_Cylarne Author
Lord_Cylarne

If you've not read the FAQ, please read before posting! Requires 1.86 FULL. Get it here: Moddb.com

Post bugs here: Moddb.com

FAQ: Moddb.com

Sneak Peaks: Youtube.com

Update video and changelog coming soon!

NTCore 2.0 (For steam users): Moddb.com

Reply Good karma+2 votes
Lord_Cylarne Author
Lord_Cylarne

Changelog: Mediafire.com

Reply Good karma+2 votes
VoidLight
VoidLight

3rd person to get it!

Reply Good karma Bad karma+3 votes
Psycode
Psycode

congratz dude lol

Reply Good karma Bad karma+3 votes
piplip2010
piplip2010

Congratulations! *Said in a snobby voice*

Reply Good karma Bad karma+1 vote
Kriegtooth
Kriegtooth

Neat! Will check it out soon! Keep up the great work! :D

Reply Good karma Bad karma+2 votes
crowman
crowman

Great thanks for that much appreciated

Reply Good karma Bad karma+2 votes
Guest
Guest

Where are the extra mine upgrades, or are they not included yet?

Reply Good karma Bad karma-1 votes
Lord_Cylarne Author
Lord_Cylarne

Read changelog. Not included yet.

Reply Good karma+1 vote
nuruddinshah52
nuruddinshah52

IT HERE!

Reply Good karma Bad karma+1 vote
Deathz_Jester
Deathz_Jester

My ingame menu displayed version is 1.86.17.... is that correct or did I do something wrong?

Reply Good karma Bad karma+2 votes
Lord_Cylarne Author
Lord_Cylarne

I forgot to add the DIDHT module file. :| Not your fault.

Reply Good karma+2 votes
nuruddinshah52
nuruddinshah52

That why I can't the new faction
(faceplam)

Reply Good karma Bad karma+1 vote
nuruddinshah52
nuruddinshah52

*play

Reply Good karma Bad karma+1 vote
Jyhor52
Jyhor52

I can play the new factions, watcha talking about, its only a slight text error

Reply Good karma Bad karma+1 vote
nuruddinshah52
nuruddinshah52

Seriously text error that all?
but can play the latest version

Reply Good karma Bad karma+1 vote
ZZ_Manu_ZZ
ZZ_Manu_ZZ

Hey i had the same error. Check when u initiate the installation. My game directory is "C:\Archivos de programa\THQ\Dawn of War - Soulstorm" but the route of the patch says "C:\x\x\Dawn of War Soulstorm" WITHOUT THE SLASH ( - ) BETWEEN "Dawn of War" and "Soulstorm". I reinsttalled adding the SLASH ( - )

Reply Good karma Bad karma+1 vote
MBInc(ARV1993)
MBInc(ARV1993)

as always .... GREAT EPIC MAGNIFIC!

Reply Good karma Bad karma+1 vote
LordDWM
LordDWM

Awesome like always :)

Reply Good karma Bad karma+1 vote
Jyhor52
Jyhor52

Yus its here! Great work as always, but i have a doubt, why does the CSM and the Daemons have the same penalty for invulnerability? Theyre completely different skills, CSM is the OP one which grants global invulnerability to everything, the Daemons one, can only target a single unit, please look into this, theyre back to being bad again for the Daemons :x

Reply Good karma Bad karma+1 vote
Blyadolubov
Blyadolubov

thats cool ability for CSM. Maybe demons dont need it - global invulnerability

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

Global invulnerability? Is that actually a thing? If so, it should be severly removed.

Reply Good karma+1 vote
Washeek
Washeek

Well when you cast invul when playing tzeench chaos sm it works for a limited time on all units - it even says so in the description ;-)

Reply Good karma Bad karma+1 vote
Jyhor52
Jyhor52

Death Cult Assassin damage increased by 1000%. Is now extremely deadly to all commanders and infantry alike, killing them almost immediately if engaged. O_O boy i need to try these

* Scout Bolters no longer deal suppression Fire. Nooooooooooooo i had so much fun with those, rendering useless tier V relic units was fun, RIP.

Warrior Venom Cannon cost increased from 70 to 100 requisition.

Wow thats quite a nerf bat, not only the squad is more expensive and takes longer to field, but you have to pay 600 requision to give them proper weapons.

Reply Good karma Bad karma+2 votes
_Christoph_
_Christoph_

You write here that 4 game breaking issues are fixed, and in the changelog i read only 3 major game breaking bugs. How much bugs do you fixed 3 or 4?

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

4. But I guess I left 3 in there by mistake. :S

Reply Good karma+1 vote
madhatter70
madhatter70

Are Erathis icons still targeted for one of these 1.86 patches?

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

Never as that is his mod which you can copy overt o UA. :)

Reply Good karma+1 vote
Zeidra_Senester
Zeidra_Senester

I play again since 1.86, and my favourite faction is Eldars… and you give love to Eldars !!
BTW is it normal that if you hide all your buildings and troops, the IA slow down a lot ? I mean, even in the hardest difficulty, if you play hide and seek with Eldars, you are 99% sure to win easily.

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

What is IA?

Reply Good karma+2 votes
Marine452
Marine452

I think he means AI.

Reply Good karma Bad karma+1 vote
Washeek
Washeek

What is with the winconditions? Someone sent you a copyright notice?

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

What?

Reply Good karma+1 vote
Washeek
Washeek

The changelog - all the wincondition - changed into blah blah. I'm just curious what happened in the background, there is even a partial explanation of the winconditions being from another mod or smth...?

Reply Good karma Bad karma+2 votes
Brsk79
Brsk79

Can any error occur with multiplayer?
I mostly play that mode,so I would not like to install it and re-install due to MP problems..
Let me know! :)

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

If you installed it correctly, then you wouldn't need to worry about MP problems (and everyone else) as all there are is same data matches.

Reply Good karma+1 vote
Jeff_the_Drifter
Jeff_the_Drifter

Hey, this mod's fantastic. Been playing it for yeeeeeaaars. Just one urk: sync errors always happen when my friends and I don't install everything to a T. Exact. The sooner you get a true all-in-one install out, the better (because my friends are idiots). Thanks!

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

All-in-one will not happen unfortunately due to ownership restrictions and ethics of modding.

Reply Good karma+1 vote
Jeff_the_Drifter
Jeff_the_Drifter

At the very least, release a patch that fixes sync errors. Chrissake, guys. It keeps happening, and only on some maps. It's like map roulette, which one's gonna make the game crash next?

Reply Good karma Bad karma+2 votes
Glisu
Glisu

Any chance to import Legio titanicus to 1.86? never too many Titans at hands of IG.

Reply Good karma Bad karma+1 vote
Lord_Chimera
Lord_Chimera

Suggestion: in further updates could you give each factions a new unit/upgrade portrait or at least improve existing unit/upgrade portraits??

Reply Good karma Bad karma+1 vote
Guest
Guest

Mod manager says freeui and chaos daemons missing? Everything worked fine before the patch? Now after intro vids game crashes.

Reply Good karma Bad karma0 votes
Lord_Cylarne Author
Lord_Cylarne

Yes. It requires Chaos Daemons 2.0 now. Please read instructions before installing. Better yet, just install Chaos Daemons 2.0 in installer please.

Reply Good karma+1 vote
Avatus07
Avatus07

Awesome! A patch within a few days when I downloaded this mod, you guys are great!

I also have a quick question if anyone could answer ...
I was installing a different mod and the DoW Mod Manager was detecting a certain mod file not being installed, would anyone know? I'll provide a screenshot link:

Puu.sh

Thanks!

Reply Good karma Bad karma+1 vote
Jonathanjpowell
Jonathanjpowell

I feel like ever since the 18. patches, the AI is a hell of a lot more slower and less aggressive.

Usually my base is attacked within 10 minutes of playing, now it's more like half an hour and when they do attack, they only send a small wave.

????

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

I don't get that issue. They seem to always attack. Some exceptions are Necrons and Chaos Marines.

Try pimping up difficulty? Could be opinion based.

Reply Good karma+1 vote
Terallian
Terallian

Is this still compatible with the "Revised Fan Addons" pack? It seems "Ultimate Apocalypse" is not installed, when looking at the mod manager:

I.gyazo.com

Reply Good karma Bad karma+1 vote
ellhn
ellhn

tyranid super weapon still not working...
icon is glitching,no timer shows and everything is grey out

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

Nope, that's a confirmed fix. Make sure you installed 1.86.3 correctly. ^^

Reply Good karma+1 vote
ellhn
ellhn

it is installed correctly.
so you can use everything?u sure?

Reply Good karma Bad karma+1 vote
ellhn
ellhn

screenshoot of superweapon I212.photobucket.com
all are grey out

Reply Good karma Bad karma+1 vote
Lord_Cylarne Author
Lord_Cylarne

I'm sorry, but we even tested this and it works. I know for sure 1.86.16 does not work and I saw with my own eyes my tester, Jordan Lane nuke an AI base in 1.86.3.

Reply Good karma+1 vote
Washeek
Washeek

check your soulstorm folder. If there is another soulstorm folder located within the first, take everything from it, cut and paste into the true ss folder. You made an error when installing 1.86.3

Reply Good karma Bad karma+2 votes
Lord_Cylarne Author
Lord_Cylarne

Actually...

After investigation, it appears to be still bugged....... after the public release. :\ After our tests, something wrong happened and backported my changes. Apparently. Thanks for response! Will be fixed (AGAIN) next version...

Reply Good karma+1 vote
ellhn
ellhn

no problem man.
me thank you for the mod.
but where this problem is hidden?i cant find it in files to fix it :S

Reply Good karma Bad karma+1 vote
NickehBoi
NickehBoi

Yep yep, same for me, I was really hoping to use them this time around.

:(

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Dawn of War
Contact
Send Message
Release date
Mod watch
Follow
File
Browse
Files
Report
Report
Share
Related Games
Dawn of War
Dawn of War Real Time Strategy
Related Groups
Ultimate Apocalypse mod team
Ultimate Apocalypse mod team Developer & Publisher