Ottoman von Bismarck gave me permission to post this here until the update is posted to steam. Mod is compatible with 1.29. If you want you can do this yourself by deleting the frontend.gui file from the Grand Exhibition zip file (under interface) or inserting the frontend.gui file from this download.

  • View media
  • View media
  • View media
  • View media
  • View media
  • View media
Embed Buttons

To promote The Grand Exhibition 1.30 compatible and grow its popularity (top mods), use the embed code provided on your homepage, blog, forums and elsewhere you desire. Or try our widget.

The Grand Exhibition 1.30 compatible
The Grand Exhibition 1.30 compatible
Post article Articles

No articles were found matching the criteria specified. We suggest you try the article list with no filter applied, to browse all available. Post article and help us achieve our mission of showcasing the best content from all developers. Join now to share your own content, we welcome creators and consumers alike and look forward to your comments.

Add file RSS Files
Update for Empire

Update for Empire

Patch

Has roughly 30-something new pictures to replace missing event pictures.

TGE 1.30 update

TGE 1.30 update

Full Version

Updated to run with 1.30 (needs new frontend but still should run, fixed eventwindow.gfx/.gui

grand exhibition

grand exhibition

Full Version 10 comments

A 1.29.3 compatible version of the mod The Grand Exhibition

Comments
Sevilla Creator
Sevilla

Sorry I deleted frontend.gui, which means it no longer shows the little icons showing which modules are installed when you are starting a new game.

It runs fine without it other than that. You will need to put all the .zip and .mod files into your mod folder (identically named TGE_tgx_north_sea_empire , TGE_tgx_reichsadler etc.)

Sometimes it may say it is incompatible with current version if you had installed a previous version, just ignore this.

Reply Good karma+1 vote
DannB
DannB

I really dont understand what to do.
Yep I put everyting where it need to be.
But what about frontend.gui. I just can't find it inside that .zip file. Simply its not there.
Any Help?

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

You may also like
Iron Universalis

Iron Universalis

Grand Strategy

Iron Universalis is a total conversion mod which will begin Europa Universalis in 1935 during the invasion of Ethiopia. Several events and decisions have...

Glory of Portugal

Glory of Portugal

Grand Strategy

Historical Ideas for Portugal No historical friend with Castile

West Slavic Kinship: Heart of Europe

West Slavic Kinship: Heart of Europe

Grand Strategy

This mod introduces lots of changes ranging from the Netherlands to Poland and from Denmark to Italy. Many new provinces, cultures, historical countries...

UPDATED Better Rhodesia (Extended Timeline Submod)

UPDATED Better Rhodesia (Extended Timeline Submod)

Grand Strategy

Want to play as Rhodesia in the Extended Timeline with more flavour? This Mod's for you! Includes Custom Missions, Dynamic province names, unique Rhodesian...

Bigger War View++ - Europa Universalis 4

Bigger War View++ - Europa Universalis 4

Grand Strategy

Updates the War Overview Screen to be larger and more handy for large screens. Minimum 1650 x 1080 recommended.

Ancient Timeline: an extension for Extended TL mod

Ancient Timeline: an extension for Extended TL mod

Grand Strategy

This is a mod that will start in the year 2509 BC, so first I'll basically edit all dates in the Extended Timeline mod so we can begin on this date. This...

Follow Profile
Icon
Europa Universalis IV
Creator
Contact
Send Message
Release date
Mod watch
Follow
Share
Style
Theme
Realism
Players
Single Player
Statistics
Last Update
Watchers
6 members
Files
3