Stargate - Empire at War: Pegasus Chronicles is a total conversion for the fantastic game Star Wars - Empire at War: Forces of corruption. This total conversion will replace every single Star Wars asset of the original game with Stargate assets. This includes units, buildings, icons, sounds, videos and so much more. Pegasus Chronicles offers 3 playable races, the Ta'uri (alliance between Earth and the Asgard), Anubis (a mighty systemlord) and the Wraith. Beside these 3 playable races, you will meet many non-playable ones like the Replicators, the Asurans, the systemlord alliance, the Aschen, the Ori and many more. Each faction will have several space and land units, well known from the series or completely new ones. Contrary to our first full version for the normal Empire at War, the next release will offer finished GC maps, in which you can play through the known Stargate storylines and experience a lot of never seen missions and adventures.

Report RSS Patch 1.9.2 + Launcher Update

Based on your feedback we release the first real patch for the open beta today!

Posted by on

Hello dear community,

Based on your feedback we release the first real patch for the open beta today!

Appart from several bug fixes, like the not properly displayed Pride of Troy, we have begun to play around with the balancing of specific units. Also thanks to 23-down, who started to support us as a freelancer in the sound department, we were able to update quite a few units with a fresh set of sounds and voices. Please note that this patch does not deal with the stability issues of the GC. We are aware of this issue and working on it internally but as of now the root cause has not pinned down yet.

You can see the complete changelog below:

Code changes:
General:
- Added deconstruction for Deconstruction_Ancient_Space_Building_Sensor_SS_PP

Ancients/Asurans:
- Heavily increased the survivability of heavy fighters and bombers
- Updated the tech levels for all ships and stations
- Moros (Dreadnought version) shield strength increased by 10 percent
- Added Puddlejumper engine sound
- Added new Helia speech sound to Cruiser and Frigate
- Changed shield and hull points of the cityships
- Pride of Troy model should appear now

Wraith:
- Added Wraith Dart engine sound to (heavy) Dart and Bomber and the Exp. Dart
- The Wraith Queen and Todd no longer prevent auto-resolving battles
- Added new fire sound for the Kamikaze Dart ability of the Battlecruiser
- Increased the stength of the Wraith Queen by 30% (more health + more damage)

PP GC:
- The Ancient sensor sat is no longer buildable for the Wraith
- Increased the info screen time for all events
- Increased trigger delay for certain events to decrease the chance of multiple events triggering at once
- Updated planet descriptions: Irrelevant (land related) planetary advantages are no longer displayed
- You can no longer get access to the Aurora research before Project Arcturus was offered

Sound changes:
- Added Wraith Dart and Puddlejumper engine sound
- Added new speach sounds for Helia

Also the launcher gets another update which enables it to wrap text in the changelog section to display it properly.

All of the above changes will be distributed via our launcher. In case of issues please grab the latest version here: Mediafire.com

Thank you again for the feedback on the open beta and the launcher that reached us so far! To ensure that the entire StargateEaW team reads your input post it here: Stargate-eaw.de

Yours,
SGMG

sgmg logo min


Comments
Dalo_Lorn
Dalo_Lorn

Just a heads up, the RAM fix still isn't clearing in the compatibility check.

Edit: It would, I believe, help if I had remembered to update.

Re-edit: Never mind. Still insists I haven't installed the RAM fix.

Reply Good karma Bad karma+4 votes
MapperLocutus Creator
MapperLocutus

Could you elaborate please?

Reply Good karma+3 votes
Dalo_Lorn
Dalo_Lorn

On the surface, it's still the same issue as before - I open the compatibility checker, I run the check, and it still says the RAM fix isn't installed.

HOWEVER. Instead of downloading the patch from your website, the 'Fix' button now says it can't install and that I should run it as administrator. (Which I am already doing.)

Reply Good karma Bad karma+2 votes
MapperLocutus Creator
MapperLocutus

Juuust to be on the safe side: By "running as admin" we mean this: Stargate-eaw.de

If that doesn't help: Could you provide an error log please?
(FAQ, section 4.6 Stargate-eaw.de)

Reply Good karma+1 vote
Dalo_Lorn
Dalo_Lorn

Yes, I think I'm computer-savvy enough to know the difference between 'run' and 'run as administrator', especially on a user account that isn't itself an admin. :P (It requests administrator privileges anyway.)

Anyway, I'm still working on uploading the logs, but my best guess is that the launcher has good reasons not to find anything at a fictional location like "C:\GameData\Data\XML\GAMECONSTANTS.XML".

Edit: Okay, I've put it up on Google Drive: Drive.google.com

Log.txt is something I generated just now to get a precise fix on the compatibility check. Yesterday's Log.txt is the log from the last time I ran the launcher, which has a whole lot more stuff in it that -might- need attention, but isn't exclusively related to the compatibility check.

Reply Good karma Bad karma+1 vote
MapperLocutus Creator
MapperLocutus

Thank you a lot for the logs, they are very helpful!
I might have an idea about this, please check your PMs:)

(I've downloaded them, you can remove the link if you want.)

Reply Good karma+1 vote
abashedduke2
abashedduke2

Is there an estimate of when a fix will be out for the crashing errors in GC

Reply Good karma Bad karma+2 votes
ImperiaI
ImperiaI

Not really. I am working on it, it seems to be because of whether performance issues or because of wayward lua script(s).

You could test my (very unofficial) Wraith Dart modification. There I reduced the amount of Darts from 7 to 3 members per Squad.

Mediafire.com

Just drop that file into:
.\Star Wars Empire at War Forces of Corruption\Mods\StargateBeta\Data\Xml

I am very curious and would like to ask everyone for feedback here, how does that file influence the crash behavoir?

Does it reduce crash occurences?

Reply Good karma Bad karma+1 vote
Dalo_Lorn
Dalo_Lorn

I had a successful (if somewhat rushed) playthrough yesterday as easy Ancients. Never flew the Delphi into combat, auto-resolve notwithstanding, and managed to fight my way through to Avitus undeterred despite a seemingly dangerous amount of tactical combat. Never built the Pride of Troy, either.

My younger brother, on the other hand, sent the Delphi into battle as soon as he got it, and crashed shortly afterwards. Your theory about the Cityship and space station scripts (I never docked/undocked anything on the station, either) may not be so far from the truth as I thought.

Reply Good karma Bad karma+1 vote
ImperiaI
ImperiaI

"Never built the Pride of Troy, either."
Hehe the missing model bug of Pride of Troy is fixed with patch 1.9.2

"My younger brother, on the other hand, sent the Delphi into battle as soon as he got it, and crashed shortly afterwards."
Yeah the Cityships drain a lot of memory, I think I can improove that a bit.

Reply Good karma Bad karma+1 vote
Dalo_Lorn
Dalo_Lorn

Oh no, it was just that between the anomalous lack of a crash and my not needing a cityship (couldn't afford to buy it, either), I didn't spring for it. I -was- curious as to what its abilities did.

Reply Good karma Bad karma+1 vote
mattias6575
mattias6575

Please make the ANCIENTS a playable race PLEASE

and good work keep it up

Reply Good karma Bad karma+1 vote
XOriontheOneX
XOriontheOneX

Adding an other faction needs the very core of the game modified or possibly entire parts of it rewritten so it has everyithing the others do. In fact doing it is so complex that creating an other GC is 100 times easier(if we have the unit models already), i looked into the codes and i was unable to figure out entire sections of it and I've been learning coding for 3 years now, so believe it.
But anyone correct me if I'm wrong

Reply Good karma Bad karma+1 vote
ImperiaI
ImperiaI

Well, I figured out how to get up to 10 Factions in the game:

Stargate-eaw.de

These factions are fully playable in skirmish and in storyless GCs, but the issue is that they wont allow story scripting because faction based command functions of the game like "Filter_Friendly_Only" or "Filter_Enemy_Only" wont work with them (hard coded in the .exe).

In fact, I already added that ancient faction in our internal version, but my teammates voted against using that version without story support during the last weeks before release.

I think we can add a Ancient faction now afterwards.
And even other factions, but we dont have all assets to have all factions as full faction, so I guess they will be quite minor.

Reply Good karma Bad karma+1 vote
palumbo
palumbo

hi guys, question for you. i thought i had the most up todate version, but i might not. i have no option listed for galactic conquest, on skirmish space battle. i tried loading a land battle and it still shows all star wars building and units. is there another version i should try and download?

Reply Good karma Bad karma+1 vote
ImperiaI
ImperiaI

You need to make sure you have settings/general/User Mode of the Launcher set to Beta, then hit the "Update button"
This brings you the Pegasus Prelude SPACE ONLY GC.

We did not released any ground mode content by now, that is still in work sorry.

Reply Good karma Bad karma+1 vote
palumbo
palumbo

thanks

Reply Good karma Bad karma+1 vote
ImperiaI
ImperiaI

You're welcome ^^

Reply Good karma Bad karma+1 vote
Lantean_Rule
Lantean_Rule

Hey guys,
This was a pleasant surprise (open beta).

I been trying to play the open beta campaign and just wanted to tell ya what I am encountering.

1. (minor)During the initial loading of the main screen, once the menus appear and the Atlantis theme music starts to play, about 3 seconds later the game play movie freezes for 3-5 seconds, then its back to normal.

2. (major)Either during loading of the space battle(not always), when increased time compression is in use (in battle or GC map), or random times I will receive the "exception" error. And when I try to make changes in Data Execution Prevention, windows indicates "This program must run with data execution protection (DEP) enabled. You cannot turn off DEP for this program. I have UAC disabled as well.

My PC hardware specs are overkill for this game, so I don't think anything other than maybe SLI might be causing an issue on my end. Also running windows 8.1.

As a former modder I understand what it takes to make something like this. I just wanted to pass some info along. Again, THANK YOU for all the hard work.

Reply Good karma Bad karma+1 vote
ImperiaI
ImperiaI

"about 3 seconds later the game play movie freezes for 3-5 seconds, then its back to normal."

A normal technical effect in the EAW engine I fear. This happens because our costum lua script for the menu background map loads almost all ships for the background fight at the same time which engages all memory, or all memory the game engine reserves for itself from your computer.

The mod is not as stable as we want it, thus it unfortunately crashes that often when loading/saving.

"My PC hardware specs are overkill for this game"
Indeed your computer doesen't reach its limits, we believe the engine still does that as it was concipated over a decade ago.

Sorry for the late reply by the way, I just returned from hollydays.

Reply Good karma Bad karma+2 votes
Guest
Guest

Why when I try to update the mod the launcher keeps saying it is looking for updates

Reply Good karma Bad karma0 votes
ImperiaI
ImperiaI

I guess you need to set Settings/General/User Mode to Open Beta, sorry for the bug.

Reply Good karma Bad karma+1 vote
mattias6575
mattias6575

it whoulde be Awsome if you added the Ancients to the skirmish MODE and lowered the cost of evry thing on the Ancients Faction (NOT IN CAMPAIN MODE THOE)

PLEASE and i like this mod so thats why i am asking :)

Reply Good karma Bad karma+1 vote
ImperiaI
ImperiaI

Yeah I guess we will add the Ancients to skirmish, not sure about the costs. They will probably stay as Ancients are quite overpowered.

Reply Good karma Bad karma+1 vote
Guest
Guest

in betaplayers the galaxyconquest crash, windows tell me that there is an error on text, and for this reason the game can't continue run, and the chage faction on setting , for example change from tau'ri to asgard doesn' work.

thnks, and sorry fom my bad english

Reply Good karma Bad karma0 votes
ImperiaI
ImperiaI

"and for this reason the game can't continue run, and the chage faction on setting , for example change from tau'ri to asgard doesn' work."

No, that only works in one of my test versions of the Mod. New factions were not implemented by now.

Reply Good karma Bad karma+1 vote
Surik_at
Surik_at

How to install this patch? My launcher says that 1.4.1 is the last version

Reply Good karma Bad karma+1 vote
Pukooo
Pukooo

Make sure your user setting is on Open Beta and not User. I have seen other people talk about this. And I set mine to Open Beta, then checked for updates. Mine is currently working to download all the way up to 1.9.3.

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Star Wars: Empire at War: Forces of Corruption
Contact
Send Message
Homepage
Stargate-eaw.de
Release date
Mod watch
Follow
News
Tags
patch, release
Browse
News
Report
Report
Share
Related Games
Related Groups
Stargate Modding Group
Stargate Modding Group Developer & Publisher