Advanced mod: Revived is a Home World 2 modification that specializes in taking the 2 existing races and expanding upon them. The idea, is to add in multiple different new ships, re-arm every ship in the game, and specialize each ship with a blended, but still clear role. By giving the player more options, and doing it in a professionalized manner the mod "advances" the gameplay of Homeworld 2 into something different, something more fun, and yet still tactically fulfilling.

Forum Thread
General Technical support. (Games : Homeworld 2 : Mods : HW2 Advanced Mod: Revived : Forum : Technical Support : General Technical support.) Post Reply
Thread Options
Dec 24 2011 Anchor

So I made these forums, and I intend to TRY and get some use out of them. To all those players who use the mod, I request that any techincal support problems, IE bugs, misspelled words, any any other various errors with the mod be posted here so that I can swiftly fix the problem.

Game play suggestions, personal questions, or any other sort of post should be directed to the general thread to keep some form of order to things.

You can either post here, or make a new thread.

Mar 8 2012 Anchor

Having a bit of an issue with your mod right now.

After loading up I can't seem to start a vs CPU game (haven't tried anything else since it's the only mode I play), I can set up the parameters but once I try to load game the load bar stops at 'Universe' for a few seconds and then I'm kicked to the desktop.
I wondered if this was because of another mod I had loaded (Legacy Map Pack v20) so I removed that, re-loaded but the problem persists.

Could this issue be because of my rig (it is fairly old but with some upgrades)? It can run Vanilla HW2 without too much issue apart from occasional audio stutter. Or could it be a problem with my installation?
I'm by no means a computer buff but I'm not clueless either so your reply doesn't have to follow the acronym "KISS" (Keep It Simple Stupid), but I'm not a modder either.


Mar 8 2012 Anchor

Hummm, I need to know a few things before I can help:
1: What version of Homeworld 2 are you running?
2: What version of the mod are you running?
3: What settings and races are you using?
4: Have you tried re-downloading, and trying the mod again?

Apr 29 2012 Anchor

I forget, what do I put in the 'Target' line on the HW2 icon? something like -advancedmodBIG right?



Apr 29 2012 Anchor

-mod AdvancedMod.big

May 8 2012 Anchor

I'm having the same issue as MetallicMonkey.

The error when it gets to "Universe" is "Error: loading research file (data:scripts\Building and Research\Invalid\research.lua)"

1: V1.1
2: V1.4BIG
3: Haven't changed a single setting from default when selecting a 2v2 map.
4: Tried re-downloading, didn't make a difference.

May 9 2012 Anchor

That is.... extremely odd... For some reason the game is expecting there to be a race called "invalid"... sounds like its having issues with the races. I have no idea as to why it would. Unless you have nothing selected for one of your players. That would push the argument of "invalid" as a race.

May 9 2012 Anchor

I didn't actually select a race for the CPU, I assumed it would be random.

After setting the race for them and pressing start, I still get stuck at "Universe". This time with "EngineTrailStatic::getTweaks requesting index(7) that doesn't exist." and the same error with Index(10). The game does successfully load though.

Strangely enough, upon exiting that game and starting a new one the error did not return.

May 10 2012 Anchor

Odd, but glad the game is working for you now.

Sep 8 2012 Anchor

hi, i just downloaded this mod, but im having trouble getting it to work. when i try to take out the file from the zip form, my computer says it cant create the file in the folder. i may have not downloaded it correctly, or im doing something wrong. im not real good at getting mods to work, and this is only the third mod for my games that i have tried to get.

i could really use some help.

okay, i just figured out one part. i dont have 1.1 update.
problem with getting it is, the check for update system on the actual game either gives me "failed to start download" or it starts the download and then stops and gives me "server error". can i download the update from some where else, and if so how would i apply the update to the game?

Sep 9 2012 Anchor

You can download and install the update for the game.
It is available Here. Just install it like any other program.

As for the mod, you should try re-downloading it first and trying again.
If you already have, or it doesn't work then I just need to know a couple things.
1: What Operating System are you running?
2: What extracting program are you using? (Windows built in, winzip, winrar, esc)

Sep 10 2012 Anchor

okay for whatever reason, my computer wont got to gamefront. are there other places i can get the update?

my operating system is windows 7 home premium OA
the extracting program is jzip.

im not computer illiterate, but im not good enough to be able to fix this problem myself, and i cant get updates i download manually to work. i dont know why or how to get them to install.

okay, well the gamefront link worked, and i got the update downloaded and applied. easier than i thought it would be.

do i have to download each successive update to the mod, or just the newist one? that might have been my problem before

could you put like a walkthrough of installing the mod, cuse i cant figure out whats going on. i may be the jzip causing the problem, but i dont think so. i dont think im doing it right. im just trying to put the advancedMod_BIG file extracted straight to the homeworld 2 files, and i think thats wrong

Sep 11 2012 Anchor

All you need is the newest version of the mod, dont worry about the older versions unless you want to try them out.

As for a walkthrough, there is a readme file in the zip which covers installation, it reads as follows:

Once the contents of the zip file have been unzipped take the big file and drop them into your HomeWorld2/Data folder. (usually located in "C:\Program Files\Sierra")
(you can usually unzip by right clicking the file and selecting unzip.)

Once finished with that, make a copy of your Homeworld 2 shortcut.
(Do this by right clicking the shortcut and then click on copy, then right clicking an open space on the desktop and  clicking on paste)

Rename the shortcut to what ever you like. (I usually like "Homeworld 2 Advanced Mod".
(Do this by right clicking the shortcut and selecting rename.)

Open up the properties on the new shortcut.
(Do this by right clicking the shortcut and selecting properties)

And add -mod AdvancedMod.big to the end of the Target in the properties.
(should look something like this: "C:\Program Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe" -mod AdvancedMod.big)

Click apply, then ok, and your new shortcut will start up the mod.
Sep 11 2012 Anchor

YES IT WORKS! thank you for your help, and the mod looks great. love how you made the capitalships far less susceptible to strike craft. i have lost battlecrusiers to strike fighters because the crusier could not shoot down the strike craft. i will definately enjoy this mod for a long time comming

Sep 11 2012 Anchor

I am glad you have it working, and that your enjoying it.

Happy to help.

Dec 8 2012 Anchor

ive tried downloading this for windows 8 and its not working after following all of your directions

Dec 9 2012 Anchor

Hummm, I do not personally have windows 8, and haven't tried it yet either. I will have to look into getting this to work, but currently have no idea where or even how it is different.

Mar 2 2013 Anchor

I have been using windows 8, and have been having the same problem as texas13, even though I did put down the correct target, the mod wont work!
I am using v 1.5 for the mod
my homeworld 2 is at v1.1
and I am using the built in windows method of moving files around, would it work better with WINRAR?

Nov 16 2013 Anchor

AH i have an issue with the mod, plz help
When i try and change this bit under the short cut properties "C:\Program
Files\Sierra\Homeworld2\Bin\Release\Homeworld2.exe" -overridebigfile)
It wont let me do it????
Don't no what to do please help

Nov 21 2013 Anchor

@Hades101 Have you made sure that your shortcut is not security controlled? I'm not sure just to what extent Windows will disable edits on shortcuts (mainly because I work hard as soon as I install windows to disable all user security), but if you dont have administrative rights to edit it, it may cause those kinds of issues.

Dec 25 2013 Anchor

This is something I mentioned earlier (as a guest), but since it's likely going to take you some time to finish your next version of this, do you have any advice on how I might buff the Progenitor units as an interim solution to how weak they are? I'd simply be giving them large number boosts, not new weapons.

Note that I have NO IDEA how to mod Homeworld 2 files, and the tutorials I've gone to have outdated links. :(

Dec 27 2013 Anchor

There are a few things you can do, you can upgrade there health, and there damage output.
Health is easy: In the ship files edit the .maxhealth line.
Weapon are a little more in depth, you'll have to find the kpr weapons in the weapons folder, and increase there damage amounts. Should be a pretty simple task to complete.

BTW those files can be altered using Notepad or even Wordpad.

Mar 25 2014 Anchor

Im having some trouble with the mod. Just installed the latest version 1.5, like i was instructed to in the readme.
Everything seems fine at first but when i start a game "anny game, single or skirmish" i cant move the camara. If i try to move it say zoming in on a unit and want to see it for another angle, it ither wont lett me or "lags" slowly and uncontrollably around the unit.

My problem is in summary: I cant controll the camara to move in 3d around the units.

I am sorry for bad english and im not good with computers so anny help or advice would be nice =)
Is there anny info you might need to help me?

Mar 15 2016 Anchor

hey when I try to load up stargate mod it goes black then crashes, I done the target right, I'm on windows 10 res 1366 768 I just have no idea whats wrong.

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.