Evolution of Combat IV is a total conversion mod for Jedi Knight: Jedi Academy adding a brand new class system, improved saber combat, movie realistic characters and a wide range of other tweaks and improvements.

Forum Thread
  Posts  
V2.2 Bugs (Games : Star Wars: Jedi Academy : Mods : Evolution of Combat IV : Forum : Bugs : V2.2 Bugs) Locked
Thread Options
Feb 12 2016 Anchor

OK, so the mod has just updated to 2.2 and I've already encountered some singleplayer bugs. I must thank them for making singleplayer easier as before Patch 2.2, it was quite frustrating. I'm gonna call out the bugs in a bullet list before I forget them. EDIT: So far these bugs are in JK's Campaign and not JA's Campaign (except for the Force Push not being powerful enough and not affecting the boulder).

Darth Vader's NPC is still Desann with red clothing. Starkiller's NPC still spawns Tavion.

I've had random crashes while playing including when I was fighting the Lord Sidious NPC in the JK2 Campaign and the game crashed.

THE FORCE LIGHTNING BUG IS STILL PRESENT IN JK - I've encountered it in the JK2 Campaign after spawning Desann and fighting him. He used Force Lightning however that did not crash my game. My Force Lightning did crash the game. I have tested to see if the lightning crashes the game anyways and it does; I used Force Lightning in the air and while standing and it crashed the game.

Neither the wall on the Yavin Training level or the T3_Rift level can be completed (Heck, the T3_Rift technically can't even be started) due to Force Push not pushing the obstacles.

Weapons in JK's Campaign do not have the shots visually there unlike in JA's Campaign where they are.

More to come as I remember and encounter more bugs! Feel free to post bugs that you've encountered, whether they be Multiplayer or Singleplayer!


Edited by: moddermanEX

Feb 13 2016 Anchor

Also, on JA you can't start with your Char you can't choose force powers, Rosh keeps attacking you after you chop the second tree ( when it's not stuck). I've tried Force lightning and it does work fine for me ( i have tried it on JK ).



PS: Please Fix the effects!

Edited by: Nyloth90

Feb 13 2016 Anchor

Anyone else encountered the bug where the tractor beam cut scene doesn't trigger on the mos eisley mission? It still occurs on my game after V2.2 update

Feb 18 2016 Anchor

For JA the guns are too powerful. Stormtroopers have super automatic weapons that nearly gave me a seizure (I'm not epileptic and I have no photosensitivity) and it drained my Force Points trying to block all of those shots. I get the game is meant to be harder, but damn, I'd rather duel 6 Vaders than fight 2 stormtroopers.

Feb 22 2016 Anchor

In the Jedi outcast campaign where you need to control a mouse droid... it rather puts me in a cortosis suit ( let's say I'm inside Fyyar ).

Mar 9 2016 Anchor

The menus aren't working in SP. When I try to change character, apply button doesn't work. JA Characters button makes me resume the game instead of going to the JA window. Settings button more of the same... Something's working wrong.

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.