Ultimate collection of custom weapons compatible with all custom addons. By NoOne and Dzierzan.

Post news Report RSS Weapons Mod 4.0 has been released!

Weapons Mod 4.0 has been released! The new version adds 6 new weapons as well as changes/balances old weapons.

Posted by on

Weapons Mod 4.0 has been released!

The new version of our mod adds 6 new weapons:

  • Stick of Dynamite (Blood Alpha),
  • Electric Pitchfork,
  • Shadow Gun (Blood Alpha),
  • Naturom Demonto (Book of magic),
  • Flamethrower,
  • Submachine gun.

Other weapons have been more or less changed, so you should try them too ;).

  • Both revolvers have interruption feature disabled and they deal more damage now,
  • Life Leech has a new alternative fire animation (but it can be disabled if a player wishes that),
  • Alpha napalm Launcher uses a different projectile,
  • Alpha sawed-off has faster reload animation,
  • Wrath Heart now does random damage (electric, spirit, basic), its altenative fire doesn't deplete all ammo and it does explosive damage,
  • Beast Claws uses random fire animation,
  • Axe uses random fire animation,
  • Lupara has shell ejection,
  • Riot shotgun uses incendiary rounds,
  • Triple DZ deals less damage.
  • Balance of ammo count for some weapons

Without further talking, just go to download section and try our new version!

Remember! Weapons Mod 4.0 is no longer compatibile with GDX.

Weapons Mod 4.0


Flamer

Efork

Demento

Comments
L3d
L3d

lolz allready better than that whole blood mod pack put together.

Reply Good karma Bad karma+4 votes
klichka
klichka

are there any source ports for this game?

Reply Good karma Bad karma+1 vote
Dzierzan Author
Dzierzan

There's BloodGDX.

Reply Good karma+1 vote
Skrell
Skrell

Then why did the author write this, "Remember! Weapons Mod 4.0 is no longer compatibile with GDX." ?

Reply Good karma Bad karma+1 vote
Dzierzan Author
Dzierzan

Skrell
klichka asked if Blood has any source port and only BloodGDX is the only unofficial source port. However Weapons Mod 4.0 is still incompatible with that port because GDX doesn't use Blood.exe. If you're interested in compatible WM version, you should use version 3.5 instead.

Reply Good karma+1 vote
Skrell
Skrell

Thank you so much for your thorough and clear response!

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Follow Report Profile
Icon
Blood
Game
Blood
Creator
Dzierzan
Contact
Send Message
Release date
Mod watch
Follow
News
Browse
News
New
Post news
Report
Report
Share
Related Mods
Related Games
Blood
Blood First Person Shooter