SilverQuest is an online multiplayer roleplaying adventure game. With retro visuals, a hip soundtrack provided by creative commons, this is an atmospheric, unique, and fun online game to play with small groups of friends. Explore dungeons, fight your way to the tops of towers, and unlock secret rooms filled with loot. A classic adventure awaits the bold!

Forum Thread
  Posts  
Black Screen Problem (Both world and items) (Games : SilverQuest : Forum : Bugs : Black Screen Problem (Both world and items)) Locked
Thread Options
Nov 22 2011 Anchor

Hello all, I bought SilverQuest Son of Kentar edition a few days back and I have been trying to get it to work for the longest time but to no avail.

My problem is that I manage to enter the game just fine, make my character and enter the server. However when I enter I can't see anything in the world map, even though I get the welcome screen saying that I have the starter items in my bag. When I click the inventory icon I see everything "empty" (not showing icons) but when I put my mouse on top of a square (that has an item) it gives me its description... so they are there, I just can't see them!

I already re-installed the VB6 Runtime files over and over again, but the result is always the same. Also it seems when I enter it gives the signal that I'm the only one in the server... is it because it is empty, or somehow the connection is not done properly? (even though I enter the world with my account and character).

Here are my system specs:

Operating System:- MS Windows 7 Home Premium 64-bit SP1 CPU:- Intel Core i7 720QM @ 1.60GHz 62 °C Clarksfield 45nm Technology RAM:- 6,00 GB Dual-Channel DDR3 @ 665MHz (9-9-9-24) Motherboard:- Hewlett-Packard 365C (CPU) 62 °C Graphics:- Monitor PnP Genérico (1600x900@60Hz)- 1024MB GeForce GT 320M (HP) 57 °CHard Drives:- 313GB Hitachi Hitachi HTS725032A9A364 (SATA)- 313GB Hitachi Hitachi HTS725032A9A364 (SATA) Optical Drives:- hp DVDRAM GT30L- XKLELC PIVO1A3SPMZ SCSI CdRom Device Audio:- IDT High Definition Audio CODEC

I hope someone can help me with this problem, since I would like very much to play the game and support it to my best.

Nov 25 2011 Anchor

OK I just had the same problem.

Things that I did to fix it:

1. Downloaded and installed Service Pack 6 for Visual Basic 6.0: Run-Time Redistribution Pack from Microsoft.com

2. Set SilverQuest.exe to run as administrator in ServicePack 3 compatibility mode.

Hope it helps you fix your problem.

Edited by: Pukas

Nov 26 2011 Anchor

Thank you for your advice Pukas... I tryed it out and it didn't work, but after some tweaking and messing around, I managed to get the game to work. For some reason had to use the Register Files.exe (didn't run when desura installed it for some reason) in admin and XP service pack 3 after reinstalling the Visual basic from the link you gave me. Also I allowed the programs through the DEP system of windows (sometimes it blocks things with legit acess... it's a system diferent from UAC and that causes problems with some older games/older resources).

Againt thanks for your help, been playing it now and having a blast! =D

Dec 6 2011 Anchor

Well, glad to see you got it to work! :D

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.