Savage 2: A Tortured Soul takes the best of the FPS, RTS, and RPG genres and blends them seamlessly into an extremely addictive and complex experience. Anyone who's seen the game in action knows that each match is full of possibilities for epic moments and amazing displays of skill and strategy. Take the reigns as your team's commander from an overhead RTS perspective with superior strategic insight -- or join them on the field from a mixed action RPG and FPS view with a wide array of powerful classes and carve your path to victory.

Forum Thread
Game won't launch from Desura, does from terminal. (Games : Savage 2: A Tortured Soul : Forum : Help and techsupport : Game won't launch from Desura, does from terminal.) Locked
Thread Options
Jan 13 2012 Anchor


Trying to launch Savage 2 from Desura does absolutely nothing. I've tried to verify the install and it seems to check out ok.
However, launching the game from the terminal works just fine, but whenever I try to start a game, it does not go any further than the menu. Any tips?

I should also add that I've tried both x64 and i386 versions (after the x64 wouldn't launch) with the same results. The terminal (start the game, trying to start a local game/tutorial/practice,etc. then quitting) doesn't give me any input but this (no error messages).

"warning: The VAD has been replaced by a hack pending a complete rewrite\".

Another bug is that I'm using a norwegian keyboard, and it won't capture my @ (AltGR + 2) button. Because of this, I am unable to create a new account.

I've also tried to completely remove all files and reinstall, to no success.

Jan 13 2012 Anchor

We confirmed a bug that the is not found - as a workaround for now pls copy that file to the game/libs directory. We will push an update today which will correct that error - but you might want to fix it right now. ;) We assume that desura somehow messed up some paths (or we set them incorrectly :/ )
You can copy the @ before starting savage2 and then pasting it into the fields - or you create your account directly on the homepage at

The errormessage ""warning: The VAD has been replaced by a hack pending a complete rewrite\". is normal as a few libs are used which will be replaced in the future. This message exists for years now already :)

Hope that helped a little

Edited by: S2Stony

Jan 13 2012 Anchor

Seems it works now.

What I had to do, was to select the "Login> I have an account" for updates to procceed. It would not update unless I went to this window (I didn't even know there were updates). After the updates, I'm able to play in-game. What a strange "bug"..

Thanks for all the help :)

Just a quick note:

Paste seems to crash Savage 2, so I had to go to the site and create a new account. After having created an account, I was presented with an email notifying me of a temporary password. I then had to go to the main site, edit account details, change password (even thought the password I had registered with, not the same as the temp, was the one I wanted) from temp, to the one I had registered with, which to then I was presented with a new email telling me to confirm my "new" password.

Just a bit of a nitpick, but isn't that one step too many?

Jan 13 2012 Anchor

You only had to login once ingame - then your chosen password would have been set for you :)

Glad it worked out for you though - see you on the battlefield :)

Jan 14 2012 Anchor

We changed this to a "click this link to activate your account" email.

Dec 1 2012 Anchor

Having the same issue here on Linux.

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.