Project Zomboid is an open-ended zombie-infested sandbox. It asks one simple question – how will you die? Whether surviving in Knox County free-roam or controlling Indie Stone mascot Baldspot in his quest to save his injured wife Kate – death is always a certainty. Quite how long you manage to put it off is another matter…

Forum Thread
Linux - game does nott start (Games : Project Zomboid : Forum : Desura Support : Linux - game does nott start) Locked
Thread Options
May 30 2013 Anchor

When I try to run the game by Desura on Ubuntu 12.04 64bit it does not start. So if I run by terminal I got following error 12: [[: not foundException in thread "main" java.lang.NoClassDefFoundError: zombie/GameWindow (wrong name: zombie/GameWindow$1) at java.lang.ClassLoader.defineClass1(Native Method) at java.lang.ClassLoader.defineClass( at at at$000( at$ at Method) at at java.lang.ClassLoader.loadClass( at sun.misc.Launcher$AppClassLoader.loadClass( at java.lang.ClassLoader.loadClass( at zombie.gameStates.MainScreenState.main(

May 31 2013 Anchor

I can confirm this happens this problem happens on Mint Gnu/Linux 64-bit too. After some search on the Internet, I found this workaround:
Needed: An NTFS partition (Fat might work too) For example a usb drive works, but usb2.0 might possibly be too slow, usb 3.0 is ok.
What to do:
1. On the Project Zomboid Desura page, download the appropriate version of the game as a standalone.
2. Place the unzipped folder on the NTFS partition.
3. Open a terminal and navigate to the project zomboid folder on your NTFS partition (if you don't know, your mounted drives are probably found in /media/)
4. Execute the game's bash script using this command: bash ./
5. While trying to play the game, so errors will arise about files not found. These files exist, but their name is wrong due to capitalization. What you need to do is rename there files correctly in your project zomboid folder on the NTFS drive.

For the moment, the files I found to have incorrect naming are:
ambiantOutsideDaybirds.ogg --> ambiantOutsideDayBirds.ogg
bathit.ogg --> Bathit.ogg
batswing.ogg --> batSwing.ogg

If a developer sees this problem, this need to be fixed quick, these bugs prevent players on Linux to actually play the game without a workaround. Thanks! Consistent capitalization (or lack of it) might be beneficial too to avoid errors.

Edited by: znuxor

Jun 23 2013 Anchor

File names should never be capitalized (in fact -no- names should ever be capitalized in computer related text) -- it's difficult to read and prone to errors.

Jul 5 2013 Anchor

Can we have this fixed properly? Don't people test these things before releasing?

Jul 6 2013 Anchor

mongrol wrote: Can we have this fixed properly? Don't people test these things before releasing?

It's an alpha game after all.
I don't think that Linux people are spoilt when it comes to Linux support for games.
We want people to report any issues so the devs can fix them.

Buying a game in alpha may not be for you, then. :(

Sep 5 2013 Anchor

Is this still an issue? I haven't played in a couple of months. I guess I was hoping that they would fix some things (especially the case sensitivity problem, since it would take five minutes). I don't know if this is still what prevents me from launching in Desura. I realize that this is an early release, but seriously, it's been months, and volunteers have already done the heavy lifting as far as solving this problem.

Sep 7 2013 Anchor

would be nice if you guys could get this fixed soon. neither 32 or 64bit version work. i understand what buying alpha means but i am sure most people expect it to atleast launch.

Sep 8 2013 Anchor

This should be fixed by now. It has not been reported for quite awhile now and we got a fair ammount of linux users on the forum.

Please make sure you have the latest version?

To make sure, please download the build from here (click it):

Edited by: nasKoo

Sep 8 2013 Anchor

I'm afraid it's still present. Tried running it on my Mint 13 x64 MATE and got this output:

/.desura/games/project-zomboid $ ./ 
Exception in thread "main" java.lang.NoClassDefFoundError: zombie/gameStates/GameStateMachine$StateAction
	at java.lang.Class.getDeclaredMethods0(Native Method)
	at java.lang.Class.privateGetDeclaredMethods(
	at java.lang.Class.getMethod0(
	at java.lang.Class.getMethod(
	at sun.launcher.LauncherHelper.validateMainClass(
	at sun.launcher.LauncherHelper.checkAndLoadMain(
Caused by: java.lang.ClassNotFoundException: zombie.gameStates.GameStateMachine$StateAction
	at Method)
	at java.lang.ClassLoader.loadClass(
	at sun.misc.Launcher$AppClassLoader.loadClass(
	at java.lang.ClassLoader.loadClass(
Sep 8 2013 Anchor

Does this happen on both builds, from the Desura client AND the direct download?

Sep 8 2013 Anchor

Only the Desura client.

Sep 9 2013 Anchor

Ah, I see.
This won't be an issue once the next stable version is out. :)

In the meantime, please download the build via the direct link posted above. Sorry for the inconvenience.

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.