Forum Thread
  Posts  
mods disabled (Forums : Support : mods disabled) Post Reply
Thread Options
Feb 10 2020 Anchor

When I opened up my mod db account I went to my mod watch to see if there was any updates. But they didn't show up and I tried anything from reopening google to restarting my pc but it still doesn't show up. Then I went to Crusader Kings 2 page and saw that the mod section was greyed out for me and when I clicked it no mods appeared. Then I went to the bannerlord page and same thing happened. But when I search for the mod, it appears and it says that I am still mod watching those mods that were there previously. I have no idea what the problem can be and would be greatly appreciated if someone can help.

Feb 10 2020 Anchor

Hey GandG, could you try clicking the home button on the top left corner of the site while you are logged into your account and try again?

If you've clicked on one of the platform tabs (XONE, PS4 etc) they're filters which will only show you mods for those specific platforms, which means you won't be able to see PC mods, but by clicking on the home button it reset your filter back to normal.

Let me know if that helps!

Feb 10 2020 Anchor

yes it did work I guess I accidently clicked on the other platform mod sections thank you for your help

Feb 11 2020 Anchor

No worries! It happens from time to time for a lot of people :)

Reply to thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.