Post feature RSS Elite Mod 2.7

Elite Mod 2.7 and 2.6.1 downloads are now here on ModDB. Install 2.6.1 first, and then 2.7, which is the most recent version. Sorry for the delay.

Posted by on

Sorry for the delay in getting them here, but the installers for 2.6.1 and 2.7 are up, and the links to the changelogs are in the descriptions for the downloads. If you can, post any questions over on the official dawnofwar.info forums. I'll check here occasionally, but you'll have more luck getting answers over there.

You will need to install 2.6.1 before 2.7 to make 2.7 work.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.