Description

Ladies and gentlemen the long wait is over. Witcher Kings is now compatible with the latest build of CK2 version 2.5.2.2. This is purely a compatibility patch with no new content.

Preview
Witcher Kings 0.6.5
Comments
Guest
Guest

What I suppose to do if I want to play this mod? Sorry, I don't know what to do. I unpack and put all files to Paradox Interactive\Crusader Kings II\mod but still not working.

Reply Good karma Bad karma+2 votes
romulien
romulien

Try with the .exe installer if you're on Windows, it will be easier: Moddb.com

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.