Description

The final version of Vanilla S.T.A.L.K.E.R. Overhaul.

Preview
Vanilla Stalker Overhaul 1.0
Comments
jns.
jns.

I can't reload any of my guns. The ammo is in my inventory but the ammo counter shows 0/0.

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

I need more info. On my end there is no such issue.

Reply Good karma+2 votes
jns.
jns.

Well, what info do you need ?

Fresh 1.0006 install, steam version. Using the alternative weapon balance patch from the optional folder.

Imgur.com

maybe these screenshots make it more clear
I can unload weapons and the ammo stack in my inventory increases. I can't load any ammo in my gun though, the ammo counter shows 0/0.

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

- Did you follow installation instructions?
- Did you change: ("$game_data$ = true| true| $fs_root$| gamedata\"
- Have you restarted your computer after the installation
I checked with and without the gun balance change just now and i have no problems reloading any of the weapons.

Though the steam version makes me wonder. I tested and played it on GOG version, i don't really have steam version of the game to see if that is the problem.

Reply Good karma+2 votes
jns.
jns.

Yeah, it's installed correctly, i've been modding Stalker since 2007 ;)

The Steam version shouldn't be any different, i can try again with GOG and see if that fixes the issue.

Reply Good karma Bad karma+2 votes
Kardiofatim Author
Kardiofatim

Try to run the game from "bin" folder from xr3DA.exe and tell me if that changes anything. As far as i can remember i've read in the past that steam might cause issues sometimes and it might require reversing the game version

Reply Good karma+2 votes
jns.
jns.

aye, will do.

update: still the same, doesn't fix it.

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

Did you mess with zrp in any way? Modified anything trough Modifier.exe?

Reply Good karma+2 votes
jns.
jns.

nope

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

I just made a clean install myself, installed the mod, and i just can't replicate this issue. I'm assuming this is something with steam version of the game, there is old early access version of the mod in the archived files. You might try that one and if you do let me know if you get the same issue, also let me know if you get the issue on GOG version.
This is really weird the 1.0 is not THAT different from early access version and ea version got over 700 downloads and i can't really believe that you are the first person using steam version with this mod.

Reply Good karma+2 votes
jns.
jns.

i don't know man, it's weird.

did a fresh install, without any patches from the "optional" folder and i still have this issue.

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

As much as i want to help you i am clueless on what may be causing the issue on your end. My bet is on steam version but since i have no access to it, i can't really be sure that is the culprit. I even installed my old box version of the game, patched it to 1.0006, installed the mod and again, no issues on my end.

Reply Good karma+2 votes
jns.
jns.

Installed on the GOG version and it's working perfectly fine now.
Guess the steam version is the culprit here lol. Any logs or files you need in case you wanna troubleshoot steam version compatibility ?

Reply Good karma Bad karma+2 votes
Kardiofatim Author
Kardiofatim

You could send me your user log, but i guess i need to get myself a steam version of the game to see what's up with that.

Reply Good karma+2 votes
Kardiofatim Author
Kardiofatim

What does "-sjitter" command do (Steam Game Launch Option)?
Also try to disable ammo aggregation script.
Open "_z.script" located gamedata/scripts
Go to line 21 "ammo_aggregation = true" And change it to false.

Reply Good karma+2 votes
jns.
jns.

-sjitter softens shadow edges, you can run 1024 smaps and it still looks good

as for the rest: gonna try that, gimme a min

Reply Good karma Bad karma+2 votes
Thricee
Thricee

Pretty nice so far, gave it a test last night. Couple issues - I get some extreme shadow distortions along the edges of my screens in certain areas (Tried all the border commands ect) Interiors seem super bright like it's on Static Lighting even though it's set to full dynamic. In fact, I'm noticing most things aren't even casting a shadow

Edit: May have missed a little step.. it says to run the game and turn on full dynamic lighting before adding any of the files..time to reinstall lol

Edit: Reinstalled properly, did everything the right way, issues still persist. Game seems perfectly stable, but visually it is just ugly as all hell lol, I dunno what's going on.. I'll post some pics

Imgur.com

Imgur.com

Imgur.com (No shadows whatsoever lol)

Imgur.com (Weird Shadow Bug when aiming at certain angles)

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

Did you max out graphical settings in options?
Try typing "r2_sun 1" in the console when you load the game.
If that doesn't help try removing user.ltx from documents/stalker-shoc/user.ltx or if you use steam version it might have it inside the game folder at "appdata" folder.
Also did you instal support for static lighting from optional files? This file is only required if you want to play on static lighting.
Shadows flickering around screen edges might be due to higher fov and if "r2_sun_near" and "r2_sun_near_border" is not enoug to fix it for you try lowering "cam_fov" in the console
this also might be an issue to 2k or 4k monitors.

Reply Good karma+1 vote
Thricee
Thricee

Alright I think I got it working mostly, deleting the ltx for some reason did it. Got a couple questions though.. any way to remove the constantly flying around wind/dirt stuff? Also.. what would I delete to get rid of the lens flare from the sun? It's a bit much. Also just noticing it's 10:45 AM in the game but there's hardly any light?

Imgur.com (Has the flying stuff I'm talking about and did the sun explode or something? Lmao)

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

Removing Wind/Dirt effects or Flares - not really if you delete flare files it will crash your game so to make them go away you'd have to make them transparent with image editor.
No sun? Weird, have you tried restarting the game? Or try changing the level? Load the game press ESC then J when main menu pops up and jump to garbage. I haven't experienced such issue and im not really sure what is that about.

Reply Good karma+1 vote
K0SS4
K0SS4

Hey. Great mod but I have one question. How to disable your subtitles? I mean don't take me wrong they're good i guess but I'm playing in polish and the mod just replaced the original subtitles with like filenames(?) and the only thing it displays is some garbage. There's also no dubbing. SO is there a simple way to disable that and get the original voices, subtitles back but enjoy the rest of the mod? I don't want to use any .exe files because I'm playing on linux(proton on steam). Thanks

Reply Good karma Bad karma+1 vote
K0SS4
K0SS4

Okay, I checek it and I can use Modifier.exe through wine and it works but there's no option for vanilla subtitles and voices

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

To disable subtitle mod you need to go to options > sounds while you have pause menu (the simulation is running) and simply chose no subtitles, to get the original dubbing back you need to remove "character_voice" folder from gamedata/sounds, though this will also remove new monolith responses.
So if you want to keep those you need to remove everything from "characters voice" beside human_01/monolith, human_02/monolith, human_03/monolith.
If you want text to be changed back to original language like dialogue menus etc. well this is a little more complicated because simply deleting the new text files (gamedata/config/text/eng) will cause crashes as there are new strings and descriptions that will either be missing or/and will crash the game when not present. So you would need original text files from your language version and then something like winmerge to compare and merge the files so the new strings, descriptions etc. would remain English but the majority of the text would be back in its original language.
Oh and don't use modifier.exe if you don't know what you are doing you will most likely mess up your game. I should have removed that but i forgot.

Reply Good karma+1 vote
K0SS4
K0SS4

Okay, I changed deleted the files beside the monolith ones and the dubbing works fine. How do I enable subtitles(even english from the mod) because it doesn't display what it should display I guess

Imgur.com

If the subtitles mod is enabled all I see are thing like on the screenshot above. I just want any text that makes sense in these places and it could even be english subtitles from the mod.

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

Go to gamefolder/gamedata/config/text
Change folder name from "ENG" to "POL" (without quotation marks) this should fix that, the text will be in English but it will be proper text instead of string references.

Reply Good karma+1 vote
K0SS4
K0SS4

Thanks will try. And one more question. I found like 3 stashes and all of them were empty and one was just missing(goods of the shooter) and the box wasnt even there. Is it a known issue?

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

You are the first one reporting such issue, i mean i know that vanilla stalker had some issues that rarely caused stashes to spawn empty but i think zrp fixes that, honestly as i was testing i never came across such issue. And "goods of the shooter" Is that small toolbox at the very top of the mill missing? I don't know how familiar you are with the game but that one is a tricky stash you really need to climb at the very top of the building stairs->wooden planks to roof> higher roof> and the small toolbox should be at the bottom of a small "cabin" of the highest roof at the right wall if you look at the rookie village direction.

Reply Good karma+1 vote
K0SS4
K0SS4

Yeah i know exactly where this stash is because i got it yesterday on vanilla and it wasn't there this time. And actually that's the only problem bacuse i forgot that I have to get info from someone's PDA before getting the stash. But i had a mark on the map with goods of the shooter so that's not the problem here.

Reply Good karma Bad karma+1 vote
Kardiofatim Author
Kardiofatim

I don't know man as i said there is a rare issue with stashes spawning empty maybe that was that, though you're mentioning that you run a steam version of the game which has higher probability of causing issues and additionally you run it on Linux, well I'd prepare for more surprises if i were you. Nonetheless, feel free to report other issues with the mod if you get any.

Reply Good karma+2 votes
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

I have a problem with the sun light, it's dark

Reply Good karma Bad karma0 votes
Kardiofatim Author
Kardiofatim

Did you max out graphical settings in options? Make sure you run full dynamic lighting.
Try typing "r2_sun 1" in the console when you load the game.
If that doesn't help try removing user.ltx from documents/stalker-shoc/user.ltx or if you use steam version it might have it inside the game folder at "appdata" folder.
This should help, if not reinstall the game, reinstall the mod.

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.