Description

Uplink OS BETA v101 for the STEAM version of Uplink - Trust is a Weakness. Release Candidate 2! Getting oh so closer! :D

Preview
UplinkOS v101 BETA for STEAM
Comments
Darkinan
Darkinan

Crashes after creating a new user on a fresh install

Reply Good karma Bad karma+1 vote
Cpt.McBacon Author
Cpt.McBacon

Crap. Sorry about that, I forgot to erase some old code >_<
Re-uploading the files right now.

Reply Good karma+1 vote
Cpt.McBacon Author
Cpt.McBacon

Version 101 is currently bugged a hell lot. I'm trying to repair it right now and will re-upload when done. Sorry for the inconvenience!

Reply Good karma+1 vote
Cpt.McBacon Author
Cpt.McBacon

It's now fixed! Enjoy and sorry again! :D

Reply Good karma+1 vote
Guest
Guest

good job man ,
really i like it ,
keep do that

gz

Reply Good karma Bad karma+1 vote
Cpt.McBacon Author
Cpt.McBacon

Thanks a lot! <3

Reply Good karma+1 vote
JohnMarchant
JohnMarchant

Crash city here after creating a new account. Im wondering if its Windows 10.

Reply Good karma Bad karma+1 vote
KCV
KCV

It's most likely that considering Uplink came out in 2001(?) and while UplinkOS changes that, it only changes the UI files, the original 2001 files are still there so yea, just use Windows 7, no clue why people use Windows 10, it's crap.

Reply Good karma Bad karma0 votes
Cpt.McBacon Author
Cpt.McBacon

The OS shouldn't be a problem... Can you please give me more details about the crashes? Does it crash right after selecting the gateway location in the new user screens? If so, when did you download the zip archive?

Reply Good karma+1 vote
JohnMarchant
JohnMarchant

Actually ive sorted it out. It was crashing when i tried to create a new account and then it crashed whilst connecting to gateway. I uninstalled and reinstalled Uplink from steam and then installed the latest UplinkOS, now everything seems to be working.

Reply Good karma Bad karma+2 votes
Cpt.McBacon Author
Cpt.McBacon

Glad it worked out! Enjoy!

Reply Good karma+1 vote
soccermitchy
soccermitchy

Is there a Linux build of this?

Reply Good karma Bad karma+1 vote
Cpt.McBacon Author
Cpt.McBacon

It's not likely it will happen, unfortunately. :/

Reply Good karma+1 vote
Guest
Guest

Hey dude ... This is awesome m8!... really gave that game a facelift...

I have a few request/ideas tho:

Could we get some better hardware upgrades?
You know, just rename the current ones to something a little better...
Like - instead of "200 MHz "TURBO" CPU"
We could maybe get an "Intel Xenon e5 18-core chip" or an i7 core and so on...
And the memory - I found that confusing. I thought it was RAM.
But it's Hard drives... So how about renaming those to storage space and SSDs ... Maybe up the volumes on disks... 128 Gb isn't that much, it's roughly what my video editor uses to cache.
You get my point...
I just think it would be really cool to see some nice components...
(It powers my nerd-boner.) .

Reply Good karma Bad karma+2 votes
Guest
Guest

Oh yeah... I almost forgot.
It really needs to be harder to hack the banks...
It's very easy to find accounts with millions on them...
Just a few days ago I found an account with over 90.000.000c, that made the rest of the game a little boring...
I don't know if you can do anything about that - Would appriciate that tho.

Keep up the good work.
Cheers.

Reply Good karma Bad karma+1 vote
axeteam
axeteam

Could not create the Display! Reverting to safe mode.

Reply Good karma Bad karma+1 vote
Guest
Guest

Same, "Could not create display! Reverting to safe mode."

Reply Good karma Bad karma+1 vote
Hockeyhacker
Hockeyhacker

While I could not get the mod to work in full screen (Could not create display Reverting to safe mode) I did eventually get it to open up in windowed mode... reverted to the original Uplink.exe, put it in windowed mode, switched back to the UplinkOS.exe and it still wasn't showing on screen (my guess is it's default position is on a second or third monitor and I don't have my extra monitors hooked up right now because I am in the middle of moving) so in the task bar I held shift and right clicked the process a few times until the option to move the windows was no longer greyed out clicked it then hit an arrow key and finally got it to show up on the monitor (which is part of why I believe that its default starting position is on a second monitor and why the game is not able to create display, because its trying to full screen on a second monitor which doesn't exist). Fairly annoying bug, but at least it can be worked around.

Reply Good karma Bad karma+1 vote
Cpt.McBacon Author
Cpt.McBacon

Ah wow, thanks a lot for the explanation - that could certainly be the cause. I'll look into it, hopefully it's not related to the graphics library!

Thanks!

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.