Description

THIS MOD REQUIRES SOURCE 2013 MULTIPLAYER UNDER THE "beta_test" VERSION. IT ALSO MAY REQUIRE HL2:DM BUT I'M NOT SURE. This is a very in-alpha version. VERY. As such, not all the features that will be in the first actual release (1.0) will be in here, and EVERYTHING is either placeholder or subject to change. Find the changelog and install information by clicking "READ MORE" down there. Yep. That one.

Preview
Skirmish Alpha (0.1)
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.