Description

Required maps and arming files for Morbus 1.4.5! Make sure you overwrite your old arming files with the ones inside this patch. The arming files in the map pack are not backwards compatible with previous versions of Morbus.

Preview
Morbus V1.4.5 Map Pack
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.