Add file DOOM BFA Version 1.2.5 Installer
Location
Files
Filename
DOOM.BFA.1.2.5.INSTALLER.zip
Category
Full Version
Uploader
MoDFaNGuy
Added
Size
79.21mb (83,062,526 bytes)
Downloads
242 (1 today)
MD5 Hash
e3165045fce08a3d9b792b9d098dd786
Embed Button
Embed Widget
Description

The latest Version of DOOM BFA now on an installer

Preview
DOOM BFA Version 1.2.5 Installer
Comments
burghard.reinsch1
burghard.reinsch1

OK, the launcher works fine when I just try to run the game, but whenever I try to run it with mods, I get these errors.

I.imgur.com
I.imgur.com
I.imgur.com

Reply Good karma Bad karma+1 vote
MoDFaNGuy Author
MoDFaNGuy

Are you trying to run OG DOOM 3 mods ? As it seems the doom_events.script is having a function defined differently from what the game expects. That usually happens if the mod was developed for a different version (like the OG 2004 Version)

Reply Good karma+1 vote
burghard.reinsch1
burghard.reinsch1

I thought that running OG DOOM 3 mods through pk4tobfg would make them compatible with BFG Edition.

Reply Good karma Bad karma+1 vote
MoDFaNGuy Author
MoDFaNGuy

It is but in some extend. Some mods for the OG DOOM 3 (like the one you try to load) require some extra work in order to work properly, and some others require actual porting since they rely on the DOOM 3 SDK. As it seems in that case the mod requires some extra work with it's .script files in order to work properly.

Reply Good karma+1 vote
dakotajfrye1
dakotajfrye1

Does this work with the original Doom 3 (Steam)?

Reply Good karma Bad karma+1 vote
MoDFaNGuy Author
MoDFaNGuy

No, it works only with the BFG Edition and the 2019 release (Bethesda.net)

Reply Good karma+1 vote
DarkJaguar
DarkJaguar

There wouldn't be a point. This is meant to restore content removed between versions and since you're playing the original you already have all that content.

Reply Good karma Bad karma+1 vote
Overlandpage55
Overlandpage55

when ever i open i get this error
Drive.google.com
i am using doom 3 bfg edition on steam with bfg edition x86 option

Reply Good karma Bad karma+1 vote
MoDFaNGuy Author
MoDFaNGuy

Specs?

Reply Good karma+1 vote
MoDFaNGuy Author
MoDFaNGuy

The problem is with your Intel graphics. It's not meeting the minimum requirements. At minimum it requires OpenGL 4.5 GPU. That one is not.

Reply Good karma+1 vote
Overlandpage55
Overlandpage55

wow half a year, no it doesn't work still, even though I upgraded from a core i5 4th gen to a Ryzen 3 3200U and from whatever intel graphics I originally had to Radeon Vega 3

Reply Good karma Bad karma+1 vote
MoDFaNGuy Author
MoDFaNGuy

Have you tried the latest version ? Are you sure it is installed in the right folder (DOOM 3 BFG Edition Installation folder)?

Reply Good karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

File
Browse
Files
New
Add file
Share
Related Mods
Related Games
Doom III
Doom III First Person Shooter
Tags