Description

Required Warband version is 1.168 or newer. It is a patch file so you need to override it to the main file.

Preview
Diplomacy 4 litdum v0.2 update patch
Comments
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.

Tags

Diplomacy 4 litdum v0.2 update patch has not been tagged yet.