Description

Patch 6.2 to be aplied at your 6.1 server only. If you are new to Frontlines R3L04D you only need the Definitive Version 6.2

Preview
COD4 Frontlines R3L04D - Patch 6.1-6.2
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.