Description

3.97 for moddb. Mod is feature complete, lacks VA for certain NPCs. Version is only for normal Skyrim, not SSE.

Preview
BeyondReach3 97
Comments
Shinobus
Shinobus

NEEDS DLC!!!!!! FFS!!

"3.97 for moddb. Mod is feature complete, lacks VA for certain NPCs. Version is only for vanilla Skyrim."

THEN WHY DO I NEED DLC?????

Reply Good karma Bad karma-1 votes
razorkid1 Author
razorkid1

Not SSE*

Reply Good karma+1 vote
Guest
Guest

This comment is currently awaiting admin approval, join now to view.

Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.