Description

Duke Meets Doom v3.1 1.0 You must have Version 1.4 or higher of duke3d in order to run this TC! 1.1 Extract the contents of the zip to your duke3d directory. Run doomduke.exe to play. 1.2 Do not rip or distribute this TC in any form or fashion. ©1998,Oddeye® Oddeye® is a registered trade-mark by Oddeye®

Preview
Duke Meets Doom v3.1
Comments
Guest
Guest

Wow! Nice game I will ever play in my life. It's better than washing the toilets.

Reply Good karma Bad karma0 votes
Guest
Guest

Says the exe cannot be opened on my PC

Reply Good karma Bad karma-1 votes
Superjiroun
Superjiroun

it is dos version

Reply Good karma Bad karma+1 vote
Dakorez
Dakorez

can it work for steam version?

Reply Good karma Bad karma+1 vote
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.