Description

This is the lava skin that will be used in Age of Bloodshed 1.08, but since I will not be releasing the work in progress version for a long time, I am releasing this Skin Pack early. Instructions for use are in the readme folder. You do not need African Kingdoms or Age of Bloodshed to use Lava Texture, this Skin Pack will work with ALL versions of Age of Empires II. Note: Age of Bloodshed 1.07 does not include this skin pack and this is not a required file. However, downloading this will visually improve the campaign scenario, "Welcome to Hell".

Preview
Age of Bloodshed Lava Skin
Post a comment
Sign in or join with:

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.