Imagine the largest Warhammer40k scale battles topped with balance for all races. Can you imagine your enemies being nuked by your own superweapon, or steamrolling them with many titans fighting other titans with complete balance? Then this is your mod.

Forum Thread
by member
  Posts  
Technical Issues (Mods : Ultimate Apocalypse mod : Forum : Feedback : Technical Issues) Post Reply
Thread Options 1 2 3 4 5 6 7 8 9 10
May 7 2013, 5:17am Anchor
Someone wrote:Wanted to report that I encounter the same error as faram45.Anytime someone uses Tyranids during multiplayer the game will encounter a sync error upon start.
No other changes have been made to either installation except the 1.72 update.Has anyone gotten a multiplayer game to work with the Tyranids?

I also had this problem, but then I went to the Tyranid Mod forums 0.5b2 Bug Thread at Tyranids.gameapollo.com and downloaded Zaha's Hotfix. When I had applied the Hotfix to the Tyranid Mod, it fixed the multiplayer sync error for the Tyranid Mod, but not for Ultimate Apocalypse: New Races. To fix this problem for Ultimate Apocalypse, I went to the UltimateApocalypse_NewRaces folder, then to Data>scar>winconditions. I then replaced the Tyranids.scar file found in this folder with the Tyranids.scar file found in the Hotfix.zip.

Please note that I didn't replace any other files in the Ultimate Apocalypse folders, like 'tyranids_woth.rgd', the other file found in the Hotfix.
I also haven't tested Tyranids with this hotfix applied extensively, so I can't guarantee that this will fix the sync error or that the hotfix won't create its own problems for Tyranids for you. Hopefully this works for anyone having problems with the Tyranids in multiplayer.

Edit: I get 'Fatal Scar Error - Execution Paused' when I play as Tyranids against AI Tyranids in Skirmish on the map 'Totmacher's Prison', I am unsure of whether this was a problem before I added the Hotfix Tyranids.scar or not. I tried doing a Tyranid vs Tyranid AI on a different map, and it ran fine, so I'm guessing this problem was map specific. Not a huge issue, just letting everyone know.

Edited by: Gutras

May 17 2013, 8:36pm Anchor

Would it be possible to make the game using more memory? In big scale battles the game is running slow and laggy, i have a good computer so i doubt it's the problem.

May 19 2013, 9:41am Anchor

I can't seem to get the Chaos Demons Mod to work. I downloaded the file multiple times and extract it to the proper directory using 7-zip...but every time I try this the extraction window says its finished but has a couple thousand errors in the extraction. The file never appears extracted in the Soul storm directory. HELP!

May 21 2013, 7:48pm Anchor

chaos deamons is out untill 1.73 they are being revamped

May 27 2013, 8:14pm Anchor

My friend and I get sync errors with this mod and all we're left with trying is re-downloading everything.

1. We can LAN connect and complete games with other mods.
2. I have an exact copy of his mod tree on my computer. Daemons, IDH, OP, nids, nids_gdm and UA, UA_misc, UA_NR burned wholesale onto a DVD and then copied into my SS directory. The previous versions of these folders I had were deleted.
3. Sync Error when we tried to play:
Vanilla UA
Fortress (3)
IG/Necrons vs SM
Apocalypse Rules, Annihilate, Game Timer, Restrict Game Enders & Relics (AI)

May 28 2013, 9:14am Anchor

Played six times. Game crashes(sync errors ) every 30 minutes 6 sec. (+-3 sec)
Hotfix.zip (Tyranids.scar file) - not helped(does not work ).
AI - 4 x Eldars
Players - Inquisition daemonhunters and imperial guard
Map - "lowlands ..." (max 8 players)
Difficult - "very hard"
How do I fix it?

PS Sorry for my bad English (I use translator)

Edited by: Persifal

Jun 7 2013, 2:53am Anchor

while playing against the AI (3humans vs3) the game simply stops to work after 30 minutes. human players are booted off the game do you know why?

Jun 15 2013, 5:58am Anchor

Hello.

I have trouble with this game. i am geting sync errors when playing LAN, like other members. I have everything properly installed, except the hotfix for tyranids, but we don´t play as tyranids. I even used a USB to move the files of my computer to my friend´s computer. Still the same. He has the game in english and me in spanish. I have tried everything that was suggested in the news comment section. I also tried reinstalling.
Can somebody help?

Jun 15 2013, 9:12am Anchor

same here. matter is, it only happens when playing against AI. can someone help?

Jun 19 2013, 12:31am Anchor

On multiplayer since I have the Dark Crusade unlocker I still only have four races. Can you somehow create a download where all of the races are unlocked instead of having all of the versions of Dawn of War prior to Soulstorm to do this?

Jun 19 2013, 1:40pm Anchor
TheGod-Emperor wrote:On multiplayer since I have the Dark Crusade unlocker I still only have four races. Can you somehow create a download where all of the races are unlocked instead of having all of the versions of Dawn of War prior to Soulstorm to do this?

Yes there is, but this is not the place to ask.

Jul 30 2013, 2:04pm Anchor

So since the daemons mod is currently being revamped, I only installed the Grand Release and then the 1.72.7 patch. When trying to load the campaign version of the mod, it tells me "unable to load" but it can load the skirmish version fine. Am I better off just playing with the original grand release until the daemons mods version 1.0 is finished?

Update: So I just tried playing just the Grand Release Version of the Mod, just the mod itself, nothing else added, and it WILL NOT activate the campaign version of this mod, I'm running Windows 8 if that brings any insight and I'm using the steam version, I'd love to play this mod so any help will be appreciated

Jul 31 2013, 4:19am Anchor
Lobsterkuln wrote:So since the daemons mod is currently being revamped, I only installed the Grand Release and then the 1.72.7 patch. When trying to load the campaign version of the mod, it tells me "unable to load" but it can load the skirmish version fine. Am I better off just playing with the original grand release until the daemons mods version 1.0 is finished?

Update: So I just tried playing just the Grand Release Version of the Mod, just the mod itself, nothing else added, and it WILL NOT activate the campaign version of this mod, I'm running Windows 8 if that brings any insight and I'm using the steam version, I'd love to play this mod so any help will be appreciated


The UA Campaign requires the New Races expansion, so you need to have the Tyranids, Daemonhunters and Daemons mods installed to play it.

Aug 31 2013, 1:33pm Anchor

Sorry to be a bother. I just finished installing all the little tidbits needed. The mod itself, the Tyrands, and the Daemonhunters. If the Daemons mod is necessary to make the game work, is there possibly a place I missed to download it? I'd love ever so much to play this mod but as of current it won't work. Giving me the error message when I try to activate it that, "Game failed to activate."

Edit: Good news I fixed the problem. Turns out when you don't install the mod to the Soulstorm folder, it has trouble working. Now excuse me while I go sit in the shame car for a few moments.

Edited by: ApolloMerit

Sep 1 2013, 12:31am Anchor

Hi, I uninstalled and reinstalled DoW, and upon reinstalling everything, I found that the Daemonettes for the Chaos race were just untextured wireframe looking things. Also, Chaos Daemons is somehow playable. I'm updated to patch 1.72.7.

Am I the only one seeing this texture bug with Daemonettes (and only Daemonettes), and why is Chaos Daemons playable? I thought they were taken out a few updates ago... (they weren't even listed in the army painter before I had done this reinstall.)

Chaos Daemon Daemonettes are textured, however. Which I find equally as strange.

EDIT

To add, I uninstalled UA, and reinstalled ONLY the Grand Release. The Daemonette skin seemed to be working fine. I then redownloaded patch 1.72.7 and applied it, only to have the texture screwed up again.

Also, Chaos Daemons is still playable. Don't know why.

Edited by: InterloperS91

Sep 6 2013, 3:10am Anchor

hi friends, i have a problem, my titan with space marine, assume the color pattern of first imperial guard player in game, you have solutions?

and other....

- the chaos army of khorne can't upgrade the heroes
- the button for ability infiltration of chaos space marine have no effect
- the space marine haven't the anti apocalypse ability
- the imperial guard build most valkirie transport to fully vehicle caps
- the portal of chaos and the manta tau, haven't scroll function to select units inside
- The map "ultimate apocalypse" don't spawn warlord titan, but warhound
- why the techmarine haven't the void shield? is too easy respect the our chaos nemesis
- The tau wall don't upgrade
- when upgrade the companion of imperial commander e tau leader, don't plus upgrade
- the tyranid spore, don't enter in the assimilation tower
- the necron worm don't respawn
- the orbital assault sensor have the cage launchpod how pink object
- the transporter vehicle (rhino, chimera, razorback, etc.) don't is trasportable, only for inquisition
- the bolter turret don't upgrade the fortified listening post, but in the modtools found replace
- the reaver titan many time, don't attack the marked target, but attack randomly enemy units
- the marine librarian, lose energy and life sometime, without causes
- the void shield of titans deactivate don't recharge if the titan are targetted by enemy fire (how morale bar)

for end, a question

how found the modtools DC in the SS? many object are not disponible in DC

Edited by: Ragnar-mantonero

Sep 6 2013, 9:42am Anchor

@ leon81VT: ... :O! Many thanks for such a detailed buglist!

- The Space Marine titan taking the IG color scheme is a bug known as "color bleeding". For the sake of faster debugging, is it the Warhound titan, the Reaver titan, or both?
- I'll assume you mean the Mark of Khorne Chaos Lord being unable to research upgrades for himself? I'll confirm this in-game on the internal alpha. With some luck it's already fixed for the next release.
- The infiltration button for Chaos Space Marines shouldn't be there to being with :/
They can no longer infiltrate since the Space Marines revamp, which made all Space Marines, Chaos Space Marines and Grey Knights much stronger. We'll see to remove that infiltration button as well.
- Space Marines lack the Apocalypse Inhibitor? ...whoops? Will definitively be fixed.
- You mean the Imperial Guard AI? They... shouldn't build any aircraft to begin with. That's weird. You sure you don't mean many, many Chimera Assault tanks? That would make a bit more sense. Until they unlock higher tier units, they spam the heck out of these.
- (no scrolling on Tau manta & Chaos portal) I don't play anything outside IG as often as I should, so I can't tell for sure, but that is likely something the DoW engine is to blame :/
- The Ultimate Apocalypse map is supposed to spawn Warhounds, if the description says otherwise it's because it's outdated xP
- The Techmarine having a personal shield actually makes sense imo. But I'm a everything-that's-tech-based-fan so...
- If I recall correctly, the Tau walls don't use the upgrade because it already has it integrated when built.
- "when upgrade the companion of imperial commander e tau leader, don't plus upgrade" eh? :3
- (Tyranid spores not entering assimilation tower) To be honest, I'm not sure if that's intended or not.
- ...what's a Necron worm?
- Ah yes, the Space Marine Deepstrike beacon model is all wonky. Definitively we'll work on that.
- "the transporter vehicle (rhino, chimera, razorback, etc.) don't is trasportable, only for inquisition" I'm afraid I don't understand :/
- "the bolter turret don't upgrade the fortified listening post, but in the modtools found replace" I think I should play Space Marines a bit before answering this.
- For some reason the Reaver titan's random targeting was reported many times, but somehow I don't get that behavior on my end. Last time I got to deploy a Reaver at least, which was kind of long ago. Maybe something was changed in a more recent version?
- (SM Librarian losing health & morale without apparent cause) Well that is weird. Morale could be tracked to some external events but health too? Maybe... If you were playing vs Dark Eldar, when used by the AI they can cast Rend Soul (which damages both health and morale) on any unit on the map, regardless if they have line of sight over it or not. Which is kind of very annoying, yes. Unfortunately there's no fix for this short of restricting Rend Soul altogether afaik.
- (Deactivated Void Shields not recharging when under fire) I'd have to confirm this, but it wouldn't be much of a surprise. Separating the normal behavior of the morale system for a few specific units isn't done easily.
In my case, I move my assault units in formation, with the titan(s) in a place where they can take some hits but can also get behind other of my units quickly to recharge their shields.

About the mod tools: You mean Relic's official mod tools? DC's are the latest version afaik. If you're interested in an efficient Attribute Editor I recommend you to get Corsix's Mod Studio if you haven't already, it would be no exaggeration to say it is better on every aspect.

Sep 6 2013, 4:22pm Anchor

i'm sorry for the bad language, but i'am italian and i have study english only at school:(

recapitulating ...

- The Space Marine titan taking the IG color scheme is a bug known as "color bleeding". For the sake of faster debugging, is it the Warhound titan, the Reaver titan, or both?

only reaver

- I'll assume you mean the Mark of Khorne Chaos Lord being unable to research upgrades for himself? I'll confirm this in-game on the internal alpha. With some luck it's already fixed for the next release.

that's ok

- The infiltration button for Chaos Space Marines shouldn't be there to being with :/
They can no longer infiltrate since the Space Marines revamp, which made all Space Marines, Chaos Space Marines and Grey Knights much stronger. We'll see to remove that infiltration button as well.

I want a refund of the requisition spending :lol:

- Space Marines lack the Apocalypse Inhibitor? ...whoops? Will definitively be fixed.

so great!

- You mean the Imperial Guard AI? They... shouldn't build any aircraft to begin with. That's weird. You sure you don't mean many, many Chimera Assault tanks? That would make a bit more sense. Until they unlock higher tier units, they spam the heck out of these.
- (no scrolling on Tau manta & Chaos portal) I don't play anything outside IG as often as I should, so I can't tell for sure, but that is likely something the DoW engine is to blame :/

absolute sure, i strike many time my AI allies with nuclear beamto prevent that the saturated zones valkiria :devil:

- The Ultimate Apocalypse map is supposed to spawn Warhounds, if the description says otherwise it's because it's outdated xP

:cry: I'll have to wait for you to make out the warlord titan as a unit selectable

- The Techmarine having a personal shield actually makes sense imo. But I'm a everything-that's-tech-based-fan so...

if I understand correctly, you'll put the shield also on techmarine? :D

- "when upgrade the companion of imperial commander e tau leader, don't plus upgrade" eh? :3

when I add buddies to the imperial commander or that tau (psyker, Commissioner, priest and operator vox), the button disappears for updates and to call the guard of honor

- (Tyranid spores not entering assimilation tower) To be honest, I'm not sure if that's intended or not.

in the old version was possible, the description of unity Ass.tower seems to me to tell

- ...what's a Necron worm?

guardian of the tomb,I think you call it that, is that species of millipedes metal

- "the transporter vehicle (rhino, chimera, razorback, etc.) don't is trasportable, only for inquisition" I'm afraid I don't understand :/

vehicles to transport troops as the chimera, chimera kronus pattern, rhino and razorback, you can not take on board aircrafts valkiria, and thunderhawk
PS.because the thunderhawk not shoot with that beautiful cannon possidede? fi a little cover fire would not hurt :devious:

- "the bolter turret don't upgrade the fortified listening post, but in the modtools found replace" I think I should play Space Marines a bit before answering this.

time ago, you had inserted the images of the towers changed, with flamethrowers, rocket launchers and six benches linked machine guns, but are not selectable in the game, while operating on DC modtools automatically replaces the old with the new towers

- (SM Librarian losing health & morale without apparent cause) Well that is weird. Morale could be tracked to some external events but health too? Maybe... If you were playing vs Dark Eldar, when used by the AI they can cast Rend Soul (which damages both health and morale) on any unit on the map, regardless if they have line of sight over it or not. Which is kind of very annoying, yes. Unfortunately there's no fix for this short of restricting Rend Soul altogether afaik.

I do not play against dark eldar because the game tends to crash, for reasons I could not understand

About the mod tools: You mean Relic's official mod tools? DC's are the latest version afaik. If you're interested in an efficient Attribute Editor I recommend you to get Corsix's Mod Studio if you haven't already, it would be no exaggeration to say it is better on every aspect.

I use it only to create or edit scenarios (I'm getting good at this), for the rest of the tools, I would need instruction in Italian, otherwise I can not understand how

Sep 7 2013, 10:21pm Anchor

Hey guys I'm having a Problem with my "Ultimate Apocalypse New Races" and "Ultimate Apocalypse Campaign" when I click on the game it says "Failed to Activate Requested game" and I know I Installed it correctly because I followed the Tutorial you guys Posted (Which Helped heaps by the way) and It only Does this with New Races and Campaign, I can play the Normal Ultimate Apocalypse, Chaos Deamons, Tyranids and Inquisition Deamonhunt fine but the others don't work, so please help me/

Sep 8 2013, 2:01am Anchor

"quote=TrustMe67: [can't activate NR/Campaign but all required mods work]"
Something tells me I shouldn't trust you...

...

I jest, but that is indeed odd. Without a look at your Warnings.log, and assuming you have the correct version of the Tyranid mod (which is 0.5b2. download link for convenience) and Daemons (version 0.96. convenient download link), my only suggestion is reinstall UA as a whole (no need to reinstall Inquisition/Daemons/Tyranids, just UA). If that fails, ehh... Reinstall Soulstorm? Protip: No need to reinstall mods when reinstalling Soulstorm, just back up your Profiles and Playback folders and you'll preserve your user and saved games that way. If you had Screenshots, back up the Screenshots folder too.

If that ALSO fails or you just don't want to do that, go to your Soulstorm directory and look for "Warnings.log". There's only one of this file and it definitively NOT the ones named "ErrorLog*timestamp*.txt".
What I need from Warnings.log is the final few lines (15 or so), but at least it is huge (like thousands of lines huge) it's pretty much the same if you send that or the whole file. Just upload the file itself to a file hosting service (such as filesmelt) or upload its contents on pastebin. Neither require registration and can be used for free. yay!
Ah, forgot to add: Warnings.log is overwritten each time you run Soulstorm, so you'll have to trigger that error, then close the game and not run it again before you upload the file. With the info in there troubleshooting this will be much easier.

On a final thing I should note as well: I'm going to sleep now, don't count on my response for quite a few hours xP

Edited by: HeavyMetalBreadLoaf

Sep 8 2013, 3:27pm Anchor

i find another bug.

with option "starting army" tyranids and eldar release the scar error

and a note: with starting army, the imperial guard, start with 2 reaver titan, don't is unbalanced? :O

Edited by: Ragnar-mantonero

Sep 8 2013, 3:50pm Anchor
leon81VT wrote:"starting army" tyranids and eldar release the scar error

Weird... I'll check that out. But this time I'll note it somewhere I see it so I don't forget like I tend to do with.. well everything :p

leon81VT wrote:with starting army, the imperial guard, start with 2 reaver titan, don't is unbalanced? :O

Dang it. That's definitively not intended, it's a bit of testing code leftover. Which is weird is that code is not in my end. Anyways, just extract this (Mediafire link) to your Soulstorm directory and it should fix the IG Reavers issue.

Edited by: HeavyMetalBreadLoaf

Sep 8 2013, 5:01pm Anchor

thx

Oct 27 2013, 8:54am Anchor

(Sorry for very bad English. I'm from Poland)

So... i installed Soulstorm, Tyranid mod, Daemons mod and Daemonhunt mod. At last i changed zip. parts of Ultimate Apocalypse to .rar parts and extracted it to Soulstorm folder. I launched game and choose Tyranid mod. Next i decided to play a match with AI. Everything is alright, okay. So i launched Daemons mod. And... unit names, building names, descriptions... everything new is lines like ,,160003124". (Whatever) It's strange... Next i launched Daemonhunt. (It's in polish, yaaay! :3) and i don't have any problems with that. But when i tried to launch Ultimate Apocalypse, after long while of loading, on my screen appeared information that modification can't be launched. (I don't know is this a good translation, maybe ,,failed to activate requested modification" is better)

And again... sorry for very bad english :c I hope that you're understand me.

Edited by: SepulchureX

Oct 27 2013, 11:59am Anchor
SepulchureX wrote:(Sorry for very bad English. I'm from Poland)

So... i installed Soulstorm, Tyranid mod, Daemons mod and Daemonhunt mod. At last i changed zip. parts of Ultimate Apocalypse to .rar parts and extracted it to Soulstorm folder. I launched game and choose Tyranid mod. Next i decided to play a match with AI. Everything is alright, okay. So i launched Daemons mod. And... unit names, building names, descriptions... everything new is lines like ,,160003124". (Whatever) It's strange... Next i launched Daemonhunt. (It's in polish, yaaay! :3) and i don't have any problems with that. But when i tried to launch Ultimate Apocalypse, after long while of loading, on my screen appeared information that modification can't be launched. (I don't know is this a good translation, maybe ,,failed to activate requested modification" is better)

And again... sorry for very bad english :c I hope that you're understand me.


you have test to change language of the game or of the windows? if not english platform maybe don't load

Reply to Thread
click to sign in and post

Only registered members can share their thoughts. So come on! Join the community today (totally free - or sign in with your social account on the right) and join in the conversation.